Brightness control not working

Hi, Im using Lenovo ideapad Gaming 3-15ARH05 - Amd Ryzen 7 4800h and GTX1650ti.
On Fedora 34 brightness always %100. Fn keys working, shows brightness scroll up and down but dont changing. Im tried edit grub file but not worked.

1 Like

Can you please run the following command in the terminal and paste the results:

ls /sys/class/backlight/

Some more helpful information can be found in the Arch wiki on the subject.

Also, can you please tell us how you edited the GRUB file (what guide you followed)?

1 Like

Output of your code:


I’ve tried this commands on grub


but not worked.
uname -a output:

Linux 5.12.12-300.fc34.x86_64 #1 SMP Fri Jun 18 14:30:51 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

lspci |grep -E “VGA|3D” output :

01:00.0 VGA compatible controller: NVIDIA Corporation TU117M [GeForce GTX 1650 Ti Mobile] (rev ff)
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Renoir (rev c6)

I also get this error every time I boot the system.

You can verify that the acpi_backlight kernel flag is set correctly by looking at the output of dmesg with something like:

sudo dmesg | grep -i command

If the returned command line does not include the acpi_backlight flag, you may need to use a different method for specifying it e.g. with grubby. Have a look at this guide for more information.

Additionally, the full dmesg output (sudo dmesg) can tell you more about the system error that’s displayed in Problem Reporting.

1 Like

I’ ve tried this command

sudo grubby --update-kernel=ALL --args="acpi_backlight"

not worked. I guess I will go back to Windows, because my eyes are on fire. Thank you for answers.


I seen this topic the other day, and I’ve been trying to remember what I did to fix the brightness on my x1. Through google searches and looking at my current grub config, I think my fix was to remove the acpi=off flag, but I’m not 100% sure.

You should be able test by pressing shift on boot up to get the grub bootloader and editing the kernel parameter for fedora. If it works you can make it permanent with:

grubby --update-kernel=ALL --remove-args="acpi=off"

Thanks Tom.

Hi Tom, Thanks for your answer.
There was no acpi=off flag.


Please provide the contents of:


Thanks Tom.

Hi Tom, its :

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"


Yeah looks the same as mine.

Reading back through, i seen you are using the nouveau; There appears to be a directory missing;


Have you tried the propriety nvida drivers?

Thanks Tom.

I couldn’t understand the Nvidia Optimus installation. Also, now I have to use the computer for my work. Thanks for your answers.


If you decide the look at this again, this tool should help with installing nvidia:

Thanks Tom.


Hi, im edting /etc/grub file, in tihs line; GRUB_CMDLINE_LINUX=
ı added amdgpu.backlight=0 and enter this command

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

its worked. check more AMD Ryzen 4800H Renior iGPU backlight brightness control not working (Hybrid Graphics) (Lenovo Legion 5 15ARH05) (#1438) · Issues · drm / amd · GitLab

thanks for answers


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.