Backlight control works in 5.14 but does'nt in 5.16 - where could I report this? (LEGION 5)


I want to know where I could report this problem

In my laptop I can’t control the backlight (brightness), I prevously could.

yes I’ve added amdgpu.backlight=0 in grub, actually that was the line I added to have it working in 5.14

In the latests kernels (5.16.*) I even tried removing the line and nothing (I read somewhere that with newer kernels you do not need the line in grub, but that’s not the case)

As a sideffect, I can’t install the headers for my current kernel (5.14.10 - those are not available anywhere) so akmod cant rebuild nvidia’s module for it. In other words or I have brightness in igpu or the dgpu module. Of course I could enable descrete mode and have it all working but the idea is to use the dgpu when you need it not to draw icons in the desktop and it was working

I wrote about this (Brightness control not working on 5.15.* kernels - #6 by rscmcl) a few weeks back but nobody could help us here, that’s why I want to know where I could report this. I like Fedora but this is a major issue for me. I’m tired to change the backlight through a command using the terminal.

installed kernels


kernel cmdline

BOOT_IMAGE=/boot/vmlinuz-5.14.10-300.fc35.x86_64 root=UUID=1c1e5ff4-629c-46b0-bd2e-d57c77b40b6e ro amdgpu.backlight=0 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

systems specs

  Kernel: 5.14.10-300.fc35.x86_64 x86_64 bits: 64 compiler: gcc
    v: 2.37-10.fc35 parameters: BOOT_IMAGE=/boot/vmlinuz-5.14.10-300.fc35.x86_64
    root=UUID=1c1e5ff4-629c-46b0-bd2e-d57c77b40b6e ro amdgpu.backlight=0 rhgb
    quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau
  Desktop: GNOME 41.4 tk: GTK 3.24.31 wm: gnome-shell
    dm: GDM 41.3, LightDM 1.30.0 Distro: Fedora release 35 (Thirty Five)
  Type: Laptop System: LENOVO product: 82B1 v: Lenovo Legion 5 15ARH05H
    serial: <superuser required> Chassis: type: 10 v: Lenovo Legion 5 15ARH05H
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0R33126 WIN
    serial: <superuser required> UEFI: LENOVO v: FSCN14WW date: 08/26/2020
  ID-1: BAT0 charge: 49.0 Wh (60.0%) condition: 81.7/80.0 Wh (102.1%)
    volts: 15.5 min: 15.4 model: SMP L19M4PC1 type: Li-poly serial: <filter>
    status: N/A cycles: 15
  Info: model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600104
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 2206 high: 2797 min/max: 1400/2900 boost: disabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 2589 2: 2743
    3: 1869 4: 2394 5: 2662 6: 2797 7: 2215 8: 2178 9: 2133 10: 1570 11: 2032
    12: 2249 13: 1992 14: 1968 15: 2211 16: 1700 bogomips: 92623
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA TU106M [GeForce RTX 2060 Mobile] driver: nouveau v: kernel
    bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
  Device-2: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel
    bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-3:2 chip-ID: 04f2:b6c2 class-ID: 0e02 serial: <filter>
  Display: wayland server: X.Org compositor: gnome-shell driver:
    loaded: amdgpu note: n/a (using device driver) - try sudo/root
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
    s-diag: 583mm (23")
  Monitor-1: XWAYLAND0 res: 1920x1080 hz: 144 dpi: 143
    size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
    renderer: AMD RENOIR (DRM 3.42.0 5.14.10-300.fc35.x86_64 LLVM 13.0.0)
    v: 4.6 Mesa 21.3.7 direct render: Yes
  Device-1: NVIDIA TU106 High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5
    chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.14.10-300.fc35.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.47 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
    chip-ID: 8086:2723 class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 5-3:3 chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 476.94 GiB used: 239.2 GiB (50.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZALQ512HALU-000L2 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: BL2QFXV7 temp: 30.9 C scheme: GPT
  ID-1: / raw-size: 27.94 GiB size: 27.33 GiB (97.83%)
    used: 17.94 GiB (65.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 89.8 MiB (17.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 310.63 GiB size: 304.75 GiB (98.11%)
    used: 221.17 GiB (72.6%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 34.2 C mobo: N/A
  Fan Speeds (RPM): N/A
  GPU: device: nouveau temp: N/A device: amdgpu temp: 34.0 C
  Processes: 364 Uptime: 19m wakeups: 1 Memory: 15 GiB used: 2.98 GiB (19.9%)
  Init: systemd v: 249 runlevel: 5 target: tool: systemctl
  Compilers: gcc: 11.2.1 Packages: note: see --pkg flatpak: 46 Shell: Bash
  v: 5.1.8 running-in: terminator inxi: 3.3.12

/etc/default/grub (first portion)


# menu countdown hidden
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX_DEFAULT="rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1"
1 Like

Hi there.

I just want to say that I have the same problem on my Legion 5 (AMD igpu and NVIDIA dgpu).

After installing the NVIDIA drivers I can no longer control my brightness with the slider or Fn keys. I tried adding both amdgpu.backlight=0 and all of the acpi_backlight appends to the cmdline_linux_default line but none of them worked (on other distributions like Manjaro and EndeavourOS where I had the same issue acpi_backlight=native solved the problem). On Kernel 5.14 I managed to change brightness but that’s probably because it falls back on nouveau drivers.

Also, which command are you using to change the brightness?

1 Like

the command I’m using is basically

echo 50 | sudo tee /sys/class/backlight/amdgpu_bl0/brightness

you need amdgpu.backlight=0 for it to work

found this

1 Like