No brightness control in gnome


on my Lenovo Thinkpad (with NVIDIA gpu) the brightness control keys are not working (the other FN keys are working). Also there is no slider for the brightness control in gnome.

What I have tried:

But none of them works. Only acpi_backlight=vendor gave me the slider back and when I press the FN keys, it shows that the brightness settings are changing, but it does not change the brightness.

I also see that the /sys/class/backlight folder is empty.

dnf upgrade did not help.

It does not work in the fedora live environment, too.
It works on Fedora KDE.
It works on opensuse tumbleweed gnome.

Do you have any idea?


If this is Fedora 32-Beta: follow this link :)

Sorry, forgot to mention it.
It is Fedora 31.

   Also: is this nouveau or nvidia driver?  KDE is rather yet working within Xorg session by default, so may be related (thoug i’d hear that Gnome has a default of Xorg too, for the p-driver).

It is nouveau driver, but I want to blacklist it anyways to be able to disable my dgpu.

   Try to do this with GRUB temporarily, maybe then?  Though i didn’t think that nouveau used at all if i915 or any AMD analogue is available (Gnome desktop even have a menu-entry for lanuching applications: “Launch using dedicated Graphics”)

If I deactivate the dgpu with bbswitch on startup, it still does not work.
I can see in the Gnome Settings at “Graphics”, that it is using “llvmpipe 9.0”. Is this correct? I would expect that it is using the integrated Intel graphics. Or is llvmpipe the driver for that?
Tested the Fedora 32 Beta Live Environment and it works there.
The directory /sys/class/backlight is not empty.