Your experience with GNOME Software in Silverblue

Making sure GNOME Software works great in Silverblue will be our focus for the next development cycle. I’m searching through bug reports in both upstream and downstream bugzillas, but I would also like to ask Silverblue users here what’s their experience with GNOME Software and what they would like to see improved.

5 Likes

Hello @eischmann ,
I am relatively content with how Gnome SW does it’s job, with some exceptions. The first would be when the underlying rpm-ostree and flatpak metadata is causing it some issues, there is no indication from Gnome SW that there is a problem except for a somewhat cryptic message about not being able to complete the task. I cannot remember the exact error but I see it on the occasion that either my rpm-ostree or my flatpak install is experiencing metadata conflicts/issues. Another thing I find is it is a bit slow, which I know is I’net connection dependent often, and I am in low bandwidth wasteland right now so I tend to not pay close attention to that. Annnd, at startup, it currently begins checking rpm-ostree and flatpak for update status, which is one of my habits at startup, so I have to wait for it to complete. Annnd, not really a big fan of the highlighted SW it features unless it is truly FLOSS.

1 Like

Stephen, thanks for the feedback.

To avoid automatic downloads on startup on a slow connection I recommend you mark that connection as ‘metered’. You can do it in the network settings and GNOME Software should honor it and stop any automatic downloads.

Thanks, I’ll give it a try.
Actually, on second thought I won’t. I would like the option to allow auto-update, but be presented with the choice of deciding at the time to accept it or forego it at the time depending upon whim. So for example, let’s say my computer use begins at or around the time I begin “real work”, I may be preoccupied with some other task while it is going through the automatic check’s which I would not care about since I was not using it immediately. While another time I may want to do something bandwidth sensitive immediately, and defer checking till later. I think this should be something doable and a configuration setting(s) would be delightful.

Sometimes when I start Software it does not open the GUI window and silently fails. Usually a reboot will fix the problem. Seems like there is a hung process or something blocking it. I don’t have any more information than that but maybe others are experiencing this that can pipe up.

2 Likes

I agree.

Not only in the highlighted apps, but in general…
I mean, I’m glad I have the possibility to install proprietary apps in case I need to. But I would also like to have a preference to hide proprietary apps. It’s issue 1021.

Perhaps this option might encourage distros (at least those using ostree) to include flathub repository by default?

BTW, I see great UI improvements in version 40!

I got a few points:

  1. A reboot is needed after Third party repository is added. That seems unnecessary.

  2. I notice one repository in the Third Party repository, even after enabled, the software it provides is not searchable nor discoverable in Software. But can only be installed vis rpm-ostree.

  3. The Installed tab always have an indicator of digit shown, but when visiting the tab, there is nothing to see. (Or just I don’t know what to look for)

  4. Lack of progress indicators - new user just don’t know what is happening, will just thing Software is hanging. A progress view so that it will display Software is waiting for other jobs to finish, waiting for daemon to response will provide more transparency.

  5. Some OS update do not provide details, like update for flatpak OS component’s

  6. I want to limit search to a particular source repository easily. I expect a advance search view that I can easily check which repository to search from will help.

  7. In the package details, there is a launch button to run the app. It will help user more if how to run the app from terminal is also provided.

  8. Some Silverblue related details for Apps - like reboot required after installing, etc.

In general it works fine, but there are some annoying bugs in some of the workflows:

  1. If I add a Flatpak repository, I won’t be able to install any applications right away. I have to restart gnome-software so that it can rebuild it’s cache. This is A: Undocumented behavior, B: Shouldn’t really be needed.
  2. If I attempt to install a firmware update, but my power cord is unplugged, GNOME Software will tell me to please plug it in. So far so good. But, even though it knows the firmware update can’t be installed because of this, it will still go ahead and trigger the reboot action. It shouldn’t try to trigger the reboot in that case.
  3. The way automatic update of Flatpaks works when low on disk space is not optimal. While the updates happens in the background, the system warning about low disk usage keeps spamming for every single update that happens. Should it even update apps in this case, risking that I run even lower on free disk space? Not sure.

I don’t know if this issues are related to the integration with Silverblue or they are applicable to GNOME Software in every platform:

  1. It is very confusing to know and choose what repo does an app uses. I installed the Flathub repo (great news that it will be enabled with a click in F34) and now I see Fedora, Flathub system and Flathub user options. Usually I install Flathub user given that apps from Flathub usually update sooner and I don’t need the installation to be system wide, but this is very confusing. What’s more, we cannot assume that every regular user will be informed enough to make this decision every time.
  2. The app is quite slow in general.
  3. When installing an app, the whole view will reload, which seems as if something broke.
  4. Search works very intermittently. Sometimes writing a word will show three results, sometimes it will show all of them. I usually need to delete some characters and type them again to reload the search and see the correct results, or I directly search for a package in flathub.org, which is not ideal but works more predictably.
  5. I see featured apps in the carousel banner on the home page, but there is no “featured apps” section on the home page, and featured apps are not showing up inside categories.
  6. I can only see seven recently published apps. I don’t know if this is by design, but sometimes I would like to be able to see a bigger list ordered by publish date.

Thanks for your work!

For long application descriptions, I would like to see the full app description when I hover over an app icon or its description. It is annoying to have to click and open the next window just to see that.

@eischmann

Bugs:

  1. The worst problem of Gnome Software that turns it unusable at my machine is the bug at issue 1091. I always need to kill it before use it. I hope the problem will be solved at GNOME 40. The problem persists until today at my Fedora Silverblue 33.

Improvements:

  1. Enable auto-update for rpm-ostree too (not only Flatpak)
    1. Future “auto-update for rpm-ostree” must respect metered connections too (the actual method — editing /etc/rpm-ostreed.conf — doesn’t respect metered connections).
      Actually, I need to manually update the machines of my parents. (They’ll never use the CLI and Gnome Software is broken at their machines due to the bug at issue 1091)
  2. Configurable repos prioritizing. E.g.: Set Flathub to have priority over Fedora Flatpak repo. I know that I can set this through CLI but this is not for the average Joe.
  3. Lack of progress indicators
    • We never know if Software died … A simple solution would be the option to see the “CLI output” (I would have this always enabled in the actual situation).
  4. Better rpm-ostree support:
    • Support rollback (at least, because this is essential to overcome problems).
    • Support (un)pin.
1 Like

Yes, this sounds exactly like the issue I have in SB33. Looks like it is fixed for GNOME 40, which is a good thing. :slight_smile:

+1 for setting repo priorities.

Three main things I don’t like personally:

  1. Feedback is dreadful: the progress bar is not accurate nor helpful. It does not help that GS is slow. But after 20 seconds of waiting for something to happen, I don’t know whether GS just crashed or is still doing something.
  2. Queuing is broken: I can’t install multiple things at the same time (GS reports a problem happened with the new flatpak, installing the same flatpak after the first one is completely installed works).
  3. GS still automatically updates metadata in full manual mode. Given 1. and 2. and general slowness, this makes keeping GS alongside updates from a terminal a real pita.

That last point made me mad over time and made me remove GS all together 2 weeks ago. Now I can look for update whenever I want in seconds instead of wait for minutes that GS finishes.

If talking about enhancements, not really related with GS but I would love to get a “sandboxing score”… Anything that accesses full systems or devices gets an F; all home directory, a E-; not using persistent directories or XDG folders, E, etc. Would drive privacy enhancements as a whole I bet.

  1. When upgrading from Fedora Silverblue 32 to 33 the progress bar was not working. I had to wait patiently without really knowing what was going on, only hoping it did not crash.
  2. Most of the time after I boot the system and I open Gnome Software it crashes at start-up. That’s a really bad first impression.

I use Fedora Silverblue for half a year now and I think it’s really awesome. I tried to use GNOME software at the beginning but soon gave up. I use the browser for flathub and the commandline. The main reason is that GNOME software feels slow and feedback is not good.

  • When selecting an application, there is an empty screen with progress indicator for multiple seconds until the content is displayed. Flathub.org in the browser is much faster.
  • During installation of an application, I only get progress as percentage. If something is downloaded, I would like to see the size, speed and estimated duration of the download, so I know the internet connection is limiting here.
  • When updating metadata, I also would like to get some feedback about what’s happening. If something is downloaded (that might block or be slow), that’s always interesting. Otherwise which steps we are in and how many steps there are would give the feeling, that there is actually some work done.
  • Sometimes I get the feeling, there are tasks in the background which slow down some actions, but I can’t find out which. Sometimes there are error messages, I can’t attribute to an action.
    I really like the design and the simplicity, but I also would like responsivness similar to a webpage and better control of (sometimes slow) downloads.

It’s interesting this topic came up because GNOME Software doesn’t work at all when I click it. Not sure I would have noticed otherwise if this topic wasn’t posted, but I rebooted and everything and nothing happens when clicked.

1 Like

When Silverblue just finish booting, rpm-ostreed will be processing something in the background.

Before the processing is done, Software might not work fully.

It always give me an impression that Software is not responding at all.

1 Like

I updated and got a new version of GNOME software… tried clicking it and it works great! More responsive than ever.

1 Like

On Silverblue 33 it was very slow to get started with it. After sometime passed it got the software on display. Then it seemed to work until it just stopped installing new software altogether. Just thought about this because these are the types of roadblocks that mean Linux is something for me to use but not recommendable for someone new coming in. System updates still work which is great.

For me personally the command line utilities offer a much improved experience with a constant feedback loop telling me if progress is being made or not. Earlier point about web search being a much more time time efficient remains very true for me, tend to still stick with the cli even though it does not feel faster it at least never crashes. Which brings me to the last show stopper: it has crashed more than a few times and also stalled for so long that just killing it seemed the only option.

Summa summarum for 1 glorious afternoon it seemed as though the future was already here but it really should be like that all the time. E: So it just got updated today and seems to work a lot better. Managed to install something again using it.