Your experience with GNOME Software in Silverblue

I have upgraded my Silverblue install to F34 and at first glance, Gnome SW seems quicker at starting up. It is currently performing a flatpak app update for some 15 of my installed apps.
One thing I notice that is a question for me would be the faltpaks that have “Requires additional permission”. There is no obvious way, aside from using Flatseal to do it, to grant said permissions. I did note that the details of the upgrade for the app indicate which permission(s) are required. Another would be “Unable to update: internet access is required but unavailable.” This message comes up after a couple of successful updates of Flatpaks, and won’t stop occurring unless I do a check for updates action, then after one or two updates it happens again. Also, after checking for updates I sometimes get the message “Unable to get list of updates: Daemon disappeared.” Restarting Gnome SW recovers from that message. On the plus side, I notice more feedback on what Gnome SW is doing while it is doing it, which goes a long way to preventing user frustration IMO.

I almost exclusively use the shell for updates because updating from Software Center feels clunky at best and broken at worst. As things stand today, I’d prefer a GUI that just shows the output from rpm-ostree update, flatpak update -y, and maybe the firmware update utility. Longer-term, though, it’d be nice to have a fast, reliable GUI.

One thing I’d really like is for rpm-ostree and Flatpak to download/stage updates more aggressively. Unless I’m on a metered connection, the only thing you probably need my permission for is applying the updates.

I’m on Silverblue 33, so this may not reflect improvements made since.

Still on Silverblue 32, but this has really been annoying the hell out of me:

If you log in with a regular user (e.g. non-admin) then GNOME will still automatically try to look for updates. This will result in the gsudo pop-over demanding the password for the admin user. You need to click cancel up to a dozen times to get rid of it and it keeps popping back up randomly later on. Really annoying if you’re running Fedora on a HTPC that everyone in the house uses (hence unprivileged default user) and was just watching a movie :wink:

Disabling auto-updates does not fix this. Daemons still running in the background :frowning:

1 Like

For me it mostly never opens. I try to launch it, wait a moment, but no window appears. As far as I can tell this is a very common experience.

It’s such a major bug that I’m surprised it didn’t count as a release blocker. It vastly undermines the trust of users having such an obvious bug present. (It makes me wonder what other major bugs there are that I haven’t noticed. Maybe disk encryption doesn’t actually encrypt anything?)

Thank you @eischmann for starting this thread and I would like to thank each of you for providing the feedback!

We would like to let you know that we’ve been processing the feedback and come up with some list of issues that we would like to address in the Silverblue 35 cycle (and also see what can be backported to 34). The list can be found in Taiga.

2 Likes

On the main page, sometimes only one row of applications is displayed (the recent ones).
The rest is missing and is just empty space.
Flathub and the normal Fedora Silverblue repository are enabled.

Mostly the experience is great, I do love the updates and have been able to adjust most of my daily routine. I really love the update capabilities and the speed of updates.

Unfortunately there are some issues I can’t find a solution yet and the forum still feels a bit irritating to me.

I tried to report one of the issues, but I can’t find my report anymore. The issue I do have are:

  • After a while gnome-software doesn’t start anymore - I switched to rpm-ostree and flatpak cli. In case I want more I need to reboot.
  • I don’t know how I can set the password for the encrypted disk
  • On F32 I failed to install the systemd on an encrypted btrfs - no password was ever accepted for decryption
  • The default layout doesn’t always accept my password for disk encryption
  • rpm-ostree seems to lack modules, search and provides so I use toolbox sometimes or search for a workaround to the application/lib that I wanted to have

You can change the password from the Disks application. Click on the partition and then on the button with the 2 wheels.
If the partition or drive or USB stick is empty, you can encrypt it from Disks. It will be formatted first.
If you want full disk encryption you have to do that during the installation of the OS.
Be careful which keyboard language you use when you create a password during the installation.

1 Like

I had an issue with disabling the search. No matter what I tried (disable search and all it’s options from the settings, mask the systemd services, …, set options to ignore directories via gsettings, I literally tried everything I found on any website) some miner process still started. They did not start automatically, but were started by one or another Gnome app when starting the specific app (e.g. on opening an image file).

When the miner process started it would consume 100% CPU, which created issues during video conferences (small freezes and glitches). I have more than 1 million files in the home dir and they are well organized, so I really don’t need Search options.

It would be nice if the options to disable the search truly worked. If that’s upstream problem, than a downstream solution could be if one could select during installation whether search is needed at all, or not, during installation.

Note, last time I checked this was happening in January, I am using Kinoite as a daily driver since then.

My issue with GNOME Software is it never starts up. I’ll try to open GNOME Software and nothing will happen. I have to open System Monitor, kill the process, and then re-launch it. Only then will it actually load up. The issue comes back on next boot.

2 Likes

Thank you Vala, sorry my mind must have slipped. What I wanted to say is, that I don’t know how to set the keyboard layout for the full disk encryption - during the installation I choose de_neo but when booting the layout seems to be en_US, at least most of the time. There are times when I need to type in the password 7 times (with 3 reboots) until it is accepted. I am damn sure that the password is correctly typed (for en_US).

Silverblue 33. Most times Gnome Software does not open - just silently bombs after starting. I rely on rpm-ostree and flatpak commands for updates.

1 Like

Yeah I also noticed choosing to turn off auto-updates does not actually turn them off. I do wish it would honor the preference.

I pretty much upgrade at some point everyday I open my personal laptop (which of course runs Silverblue!). It’s just I want to do it on my own terms… it’s weird but I want to see it run successfully on the command line.

One more thing, which is kind of unrelated to Silverblue itself: GNOME Software doesn’t enable filtering by toolkit/interface or license.

I know we try very hard to visually integrate QT apps in GNOME and vice versa, but I would prefer if Software would prioritise the results by type of interface. So on a GNOME desktop I’d prefer GNOME-interface-guidelines-designed apps over general GTK apps over everything else for the best and most consistent user experience. Currently stuck evaluating all my search results, having to go to their website to figure out what toolkit they use, looking at screenshots etcetera. GNOME Software’s search could prioritise the apps with the most suitable toolkit in search results, use “recommended” badges for official GNOME/KDE/whatever desktop apps or something like that.

Similarly with Flatpaks we’re getting access to more non-free software and sooner or later paid applications, so a dropdown to filter on open/closed/paid makes sense.

1 Like

the software preferences in Software do not seem to work well in gnome-software.

I have automatic update checked, but I always have to manually update the flatpaks.

The options also seem to lack the granularity for Silverblue - you may want different options to download OS/image updates compared to app/flatpak updates.

For OS updates it is a download operation and only booted into it the next reboot - that is also unclear from the options.

WHen searching for the app etc, the downloading metadata/looking for updates step makes the app unuseable. This should ideally be an atomic operation where possible. Use the old data until the new data is ready and then copy of the choices if any have been made in the mean time.

I am not sure where the problem with this is, but flatpack build of GTK-Demo4 from gnome nightly repository as version 3.99. problem might be on the repository side here.

1 Like

I had the same issue. I did a fresh reinstall with rawhide (fed34) and I don’t have the issue anymore.

Overall my major pain points appear to be fixed.

  • :white_check_mark: I can type my disk encryption password now and it works
  • :white_check_mark: Gnome software can be started hours after I booted my system
  • :white_check_mark: I’m able to boot the btrfs setup with disk encryption

The minor once are:

  • :x: rpm-ostree is still lacking modules,search and provides
  • :x: I still have to type my disk encryption password using en_UK desite defining de_neo as my primary keyboard layout during the installation. Not sure how to change it though.
2 Likes

I installed F34 Silverblue Beta a few days ago and so far Software seemingly hasn’t automatically updated any Flatpak apps a single time. On F33 and F34 Workstation Beta Software automatically updated Flatpaks perfectly fine every boot.

Same here.

See also this issue.

Thanks for asking!
In regular workstation when shutting down there is a ticked box ‘shutdown AND install pending updates’.
I find this absolutely wonderful!
I would love to see it nicely implemented in Silverblue as well.
Integration would be even better since in regular workstation the installation requires a few minutes after shutting down, while it should be logically ‘instant’ in Silverblue (just next boot will bring the new image) ;).
Eventually the naming could be different such as “shutdown and move to new branch” or something like that…

The idea is that this way of updating in workstation stays “out of the way” from workflow. After a workday you shutdown and agree the proposal of installing updates with an already ticked box, great.
No need notification or opening gnome software…
And yes thats the point here.
So yes, that would be my take for Silverblue improvement in Gnome Software: updating without the need of actually opening nor recieving an update notification from Gnome Software.

i really like silverblue with gnome at very minimal minus the whole family of gnome apps.

i wish the support for silverblue was more active.