Windows 10 bootmgr no longer shown after installing Fedora 34 to dual boot

Dual Boot of Fedora 34 and Windows 10, Now Windows bootmgr doesn’t show up, not even in BIOS, [URGENT] help needed in adding winbootmgr in Fedora Grub

So , I was trying to add to Fedora 34 alongside(dual boot) Windows 10 , saw many famous videos on youtube and read instructions on Fedora Documentation.
The only difference between my installation and youtuber’s was , While selecting partitioning, It popped up “Error checking filesystem. click to see details.”
I clicked on it … It showed
“Create a BOOT BIOS partition of at least 1MiB”
So , I Created as asked by fedora, It went all smooth, Except , now I can’t see my Windows anywhere, I can access windows files, see its partition, even grub folder has Microsoft, But no option for Windows

Output of efibootmgr : EFI variables are not supported on this system.
Please, If I can write manually to the Bootloader of fedora


First of all, find out if your system is booting in BIOS mode of UEFI mode. If EFI variables are not supported, then it is in BIOS mode.

Secondly, you need to find out if your disk is using MBR or GPT partition table format.

Normally, EFI with GPT, BIOS with MBR .

Fedora support a special mode, which is BIOS with GPT, but in this configuration, we must “Create a BOOT BIOS partition of at least 1MiB”.

Only after the above qustions are answer, then try to fix Windows Boot loader, then proceed to take care about Fedora .

1 Like


Now here you can see, Windows has EFI and Fedora made me make BIOS BOOT 2MiB partition

OK. Your system supports booting in UEFI mode, it is in GPT partition table.

When you boot the Fedora LiveUSB, your system might let you choose to boot in BIOS mode or UEFI mode.

Very likely, you selected BIOS mode, so Fedora’s installer (Anaconda) is proceeding in BIOS mode.

Please reboot with your Fedora LiveUSB in UEFI mode and reinstall.

I tried so , and the usb media is unable to write anywhere, btw can this issue be fixed if I delete the BIOS BOOT partition from Gparted OR Using a Windows Installation disc to Repair my PC >> troubleshoot>> cmd >> bootrec /fixmbr && bootrec /fixboot

Once you can boot the Fedora USB in UEFI mode, in Storage, choose custom.

Then proceed to remove sdb5, sdb6 and sdb7.

Create 1GB /boot in ext4 as sdb5
Create remaining space in btrfs as sdb6
(normally we do not need dedicated swap partition. If you want, then you can leave some space and create the swap partition.)

Mount /dev/sdb5 as /boot, format as ext4
Mount /dev/sdb1 as /boot/efi, do NOT format
Add a “root” subvol and mount it as /
Add a “home” subvol and mount it as /home

Then you can proceed to install.

How to boot Fedora USB in UEFI mode?

Using Rufus ? I should make again the bootable pendrive using rufus?

The Fedora LiveUSB can boot in either BIOS or UEFI mode.

It depends on your computer. Please access your System Firmware, and make sure USB boot in UEFI mode is higher priority than USB boot in BIOS mode.

Or, modern system supports a Boot Menu (in my system, I need to press F12 during POST to invoke the boot menu), then choose booting the USB in UEFI mode.

OKkk , Now i remember , while booting live usb , I chose USB STICK and Not UEFI Partition USB Stick

Well, I will try and tell you

Really a lot thanks!

1 Like

So, I tried and This time I chose SANDISK CRUZER BLADE : UEFI PARTITION 1
But then how? Already Linux is installed and While in Installation setup , there is no option to remove linux and reinstall it. Is there? Can you refer me a Video to help me as a guide for this ?

I am not familiar with Video tutorials, sorry.

You need to choose Custom disk option to manually select which partition to remove.

But it doesn’t show any remove option in the installer

Choose storage, then choose Custom, then click Done.

And it will present a UI to manage the disk partitions.

Now tell me what I need to do further , without risking any data of my windows and D drive

remove sdb5
expand the Fedora group
remove sdb7
remove sdb6

then click “create automatically” near the top.

sdb1, mount point /boot/efi, do NOT format
sdb2, sdb3, sdb4 not be touched
likely, sdb5 is 1G, format as ext4, mount as /boot
You will also find a /home subvol, and a
/ subvol

After all the above is OK, then can proceed to install.

Just to make sure, when you reboot your computer do you see the grub boot menu or is it booting into Fedora automatically?

If yes, confirm these settings:

  • BIOS > Boot > UEFI Hard Disk Priority
  • Swap your Fedora to boot option #1 > Windows second

If no, restart your computer:

  • Tap F11 rapidly
  • Verify if Windows is an option to select

@sampsonf Thank you very Much and you were really very Helpful. That WORKED FOR ME!

No brother’, even in BIOS or Boot menu, no option was there for Windows or anything …it just had Toshiba HDD and Micron SSD

And I am sorry for replying late, but since I am new here, It allowed me only 20 replies yesterday , which git over.

So again , Thanks to @sampsonf