VS Code UI has a monospace font

Hi,

I have installed Visual Studio code from the official repo as layered package in my F39 Silverblue installation.

Strangely, all of the UI has a monospace font instead of the Noto Sans font that I have set as the UI font in Gnome Tweaks.

What can I do about this?

Setting the UI font in Gnome Tweaks to Droid Sans instead of Noto Sans has helped once, but after restarting my computer, VS code showed the issue again. Also, it then did not help anymore to change the font.


Open settings and find the fonts it tries to use.
Then I think you can use the gnome fonts utility to install them although I am not certain.

I found that setting and reset it to defaults, but that did not change anything. As far as I understand that setting is not supposed to change the fonts of the UI itself anyway, but only the font of the text in the editor.

Another observation I made in the meantime: The issue is definitely related to my user profile. When I run VS code in a fresh user profile, everything is fine.

Also, I found that in the problematic user profile VS code seems to exclusively use fonts that are located in ~/.local/share/fonts and ignores fonts that are installed system-wide: when I delete all fonts in ~/.local/share/fonts the UI has no text at all. What’s also weird: as long as ~/.local/share/fonts contains DroidSans.ttf and DroidSansMono.ttf only, the UI shows in DroidSans and the editor uses DroidSansMono. But as soon as I add SourceCodePro.ttf, every text in VS code (text in the editor, menus and the rest of the UI) is shown in that font. I have not found any setting in Gnome or VS code that mentions SourceCodePro. Do you have any suggestions where I could look?

So sort of on the topic but … not. Did you know VSCode is based on the wonderful open sourced project Atom? And Pulsar the OpenSource project forked from Atom is available in Fedora’s repo, with no added hassle to use. It should be relatively easy to use the VSCode specific plugins for Pulsar or Atom to make your very own IDE.

Well that is a little bit too much hassle to just get the fonts right for my taste. But thanks anyway!