Newly added font not visible to add in gnome-terminal

Fedora Workstation version : 34

All this time, the way I added a font to my Fedora OS is :

I have created .fonts directory in my home directory, say , /home/keith

Then, I copy and past the .ttf file of the font to /home/keith/.fonts
I don’t know if this is the official way to add fonts in Fedora, but I think the above mentioned steps have worked for me.

I wanted to try the below font (Comic Neue from google) for my gnome-terminal.

So, downloaded and copy-pasted the .ttf files to /home/keith/.fonts directory.
Now, I can see it in the ‘Fonts’ (‘All Fonts’) directory.

But, it won’t appear in gnome-terminal > preferences (shown below :point_down:)

I tried restarting my PC. I tried running fc-cache command as mentioned in the below URL. But, none of these have helped.

Any idea why the font doesn’t appear in gnome-terminal preferences ?

1 Like

GNOME Terminal appears to require a monospaced font.


Oh ok. That seems to be the case.
Thank you Vladislav.

A similair monospaced font called Comic Mono (link below) worked ; but only after closing and re-opening a new terminal

The following popular comic sans like font is not visible in gnome-terminal though (even after adding in ~/.fonts directory).
Authors claim it is a monospace font. Yet to check if a restart of the PC will help.