Unable to add network printer

I am using Fedora 37 Server Edition with KDE Plasma Ver: 5.26.4. I am unable to connect to a printer shaed via a windows machine.
I have done connecting the same printer easily on my laptop which uses GNOME Fedora 37.
My printer is Brother HL-L2321D.
Thanks in advance.

I am guessing that when you said that your laptop is using ‘GNOME Fedora 37’ that you actually meant ‘Fedora 37 Workstation’. This can be verified with cat /etc/os-release
The workstation edition contains a lot more drivers than the server edition.

A quick search for your printer on line showed this

Yes. I am using Fedora 37 Workstation on my laptop. It did discover a network printer from ‘Add Printer’ option.

  • I have tried installing printer driver in my server edition. It only installs driver for USB.
  • While installing the driver I have tried providing DEVICE URI. But in vain.
  • I can manually select CUPS driver for that printer from network printer list. But the printer does not work.

Please suggest if I can install any driver that can give the ability to discover the printer.
Thanks in advance.

Have you set an IP address on the printer that is within your local network address range?
For example, if your local network is then you would need to set an address that is between and You also would need to look at the router and make sure the IP you choose is not within the range assigned by DHCP. You could also set the printer to use DHCP and then on the router set the printer to a ‘reserved’ address so it always gets the same assigned address.

A network (wireless) printer has to be configured at both ends to ensure an address that always remains the same. Either static assigned on the printer or DHCP reserved as assigned by the router/dhcp server.

Once you have the printer address set then setting cups to the printer address should work.
On my system I have this. Do you have the same on your server?

# dnf list *cups*
Last metadata expiration check: 2:50:15 ago on Tue 03 Jan 2023 04:51:38 AM CST.
Installed Packages
cups.x86_64                                                           1:2.4.2-5.fc37                                             @updates
cups-client.x86_64                                                    1:2.4.2-5.fc37                                             @updates
cups-devel.x86_64                                                     1:2.4.2-5.fc37                                             @updates
cups-filesystem.noarch                                                1:2.4.2-5.fc37                                             @updates
cups-filters.x86_64                                                   1.28.16-2.fc37                                             @fedora 
cups-filters-braille.x86_64                                           1.28.16-2.fc37                                             @fedora 
cups-filters-libs.x86_64                                              1.28.16-2.fc37                                             @fedora 
cups-ipptool.x86_64                                                   1:2.4.2-5.fc37                                             @updates
cups-libs.i686                                                        1:2.4.2-5.fc37                                             @updates
cups-libs.x86_64                                                      1:2.4.2-5.fc37                                             @updates
cups-pk-helper.x86_64                                                 0.2.7-1.fc37                                               @fedora 
gutenprint-cups.x86_64                                                5.3.4-9.fc37                                               @fedora 
python3-cups.x86_64                                                   2.0.1-14.fc37                                              @fedora