Printer Configuration

Just installed Fedora Workstation 35 for the first time. Setup added my printer and shows my printer in ready status with no activity, but nothing happens when I ask for a test page to be printed.

Printer is Canon MF8580Cdw which Fedora correctly recognizes as a Canon_MF8500C_Series.

The printer is connected by WiFi, and works when I boot the same computer to Windows.

1 Like

I don’t have wifi printer, but maybe you could first make sure with cable connection if this work or not with Fedora 35.


With the last few upgrades of fedora, including using full hard reinstall, my printer configuration magically followed, activating without additional actions.
My latest upgrade to fedora 35 did not do this. I temporarily disabled selinux, setting active status to “0” then clicked the printer gui set-up from my printer (it is hp) the gui automatically added printer via wifi. then re-enabled selinux setting active status to “1”

I hope this did not open a backdoor way into my system. The printer works fine now, especially scanning using XSane application.

I went through your steps, and the printer is now working … but I don’t know whether to credit your procedure or not.

When I reinstalled the printer manufally, I had three options … The first was the driver which was selected by the automatic install. The second was to use a cups driver, and the third option was a driverless install. I chose the third option and it worked. I think the driverless option might cost me some functionality. If that happens, I’ll try the other options.

In any case, thanks for getting me going in the right diretcion. I really appreciate it.


That’s solved mark, if not by you, it may be by me accidentally click the button when browsing this page from my Android. My apologies for that. I changed it to your solution now.