Brother printer not working


I’m trying to make my brother printer work either on my main OS or in a gnome boxes vm.

I’ve installed and followed the instructions on the brother website and i get the printer name in the settings section but it doesn’t work.

What i’m doing wrong?

Thanks for any help

If your printer supports AirPrint, then cups can use that. See for example This is for Debian systems, but cups is pretty much the same on Fedora systems.

1 Like

Can you please provide your configuration and installation details?
Also what model and how you connect (network, USB).

The tricky part for me (DCP-7055W, network) was figuring out what to enter for the question:

Will you specify the DeviceURI ?" => Yes
specify… => IP Address

I have a dcp-1610w and use usb ,I tried again now it works but only for printing, i can’t scan.

That’s a fairly old printer, so probably doesn’t have the newer driverless spec. Here are the Linux drivers for that (select “Linux (rpm)” from the drop down). The scanner drivers are on that page below the printer drivers. You’ll want the 64-bit packages.

I have a similar printer DCP-1617NW

I got it up and running by downloading the Driver Install Tool

  1. Copy it to a folder ~/.brother and unzip
  2. Run driver installation
  3. I put the IP address of the Printer. Among all the questions that the installer asks you. You can select the USB connection.

Note: The installer takes care of installing some dependencies.

Do you have to add the printer’s ip even when using only usb?

The device uri can be a usb:// type. Run lpinfo -v to discover it.

[root@newbox ~]# lpinfo -v
network beh
network ipp
file cups-pdf:/
network socket
network lpd
network ipps
direct usb://Brother/HL-2130%20series?serial=C4N971702
network http
network https
[root@newbox ~]# 
1 Like

Thank you. Now it works