Printing with HP network printers

cups kept finding printers on my local ethernet, but none of them worked.
I removed cups (dnf remove cups) and re-installed it. Now the address is “null” and still no printing.

Try restarting the printers. I’ve found this is necessary before a new system can print properly. The system sees the printer/scanner but has connectivity issues. eg. sane or simple-scan won’t find the printer’s scanner, even though the printer has been added.

Hello @peterblantic: welcome to the community. If you haven’t had a chance yet, please do take a look at the introductory posts in the #start-here category.

Could you give us some more information please? What version of Fedora are you on, and what make/model are these printers? Cups may detect them, but it is often the case that they need to be installed to use—since their drivers need to be installed.

Fedora 29, HP All-in-One Model 7313

1 Like

Ah, HP: for our new HP printer, even though CUPS etc detected it, we had to run hp-setup from the hplip package to get the correct drivers installed for it to start printing.

Maybe worth a go?


To add to @FranciscoD’s answer, I usually install GUI for hplip for adding/configuring HP printers and MFU’s:

sudo dnf install hplip-gui

or if you use Gnome Software graphical app to install your software it’s HPLIP Graphic Tools.

As far as I know, hplip-gui isn’t installed by default in Fedora.

Many (all?) of HP printers and MFU’s require proprietary plugins to work, and hplip is the only working way I know of to install it.

1 Like

Yay! Thanks, people. Had to run "hp-setup " after installing hplip and hplip-gui. Worked like a charm.


@peterblantic: Please mark the appropriate reply as the solution to aid others that may run into the issue too.