Silverblue - GNOME Evolution does not read/show contacts, calendars, etc

I recently switched from workstation to Silverblue (F35) and I’m having a problem getting the Flatpak version of evolution to read and show calendar events, contacts, etc from gmail accounts.

I have the accounts added through GNOME’s online accounts section and the email works fine. Calendar events do show up under GNOME calendar, so I know the accounts are being read somewhere.

Does anyone know how to fix this? Is there some permission I might need to change in the FlatPak?

This is the error I see when trying to refresh contacts in Evolution:

This address book cannot be opened.  This either means that an incorrect URI was entered, or the server is unreachable.

Detailed error message: Unable to connect to “Address Book”: Error calling StartServiceByName for Timeout was reached

I experienced same problem. Each time I need to on and off the synchronization from the GNOME Settings for Contacts app but I dont know the permanent solution.

Hi @fooze666 ,
I get that message usually after a new release (Silverblue), or an update of Evolution, but my contacts are there so I usually just close it. It seems to be having difficulty reaching the gmail server in my case, and it happens for the other email accounts I run but much rarer. I do have an extremely slow internet connection though so that could be my whole issue. There is likely a time delay that can be tweaked to prevent the error from happening, I just haven’t bothered searching through Evolution for it.

Hmm… I’ve searched all the settings and even tried looking at Flatpak settings through Flatseal and can’t find anything that I think is the problem.

As I said, GNOME shows calendar events, so I know the accounts are being read, they just don’t show up in Evolution. Strangely, some of my contacts have started to appear in Evolution and I have no idea why. Calendars, tasks, etc still don’t show up.

I’ve tried turning the account sync in gnome’s online accounts off and on but it doesn’t seem to make a difference. My connection is fast and I am not having problems connecting to anything else. It seems to be something very specific to Evolution, and particularly the Flatpak version. When running the RPM version on the regular Fedora Workstation I never had a problem.

I suppose I can kill the Flatpak and layer the RPM version through ostree, but I really hate having to do that. It defeats the whole purpose of using Silverblue.

Did you happen to stumble across this for debugging?

May be you also want to check flatpak background permissions:

[testcase@fedora 5.15.14-200.fc35]$ flatpak permissions
Table             Object              App                          Permissions Data
gnome             shortcuts-inhibitor org.gnome.Boxes.desktop      GRANTED     []
notifications     notification        fr.handbrake.ghb             yes         0x00
background        background          com.getmailspring.Mailspring yes         0x00
background        background          com.github.wwmm.easyeffects  no          0x00
desktop-used-apps video/mp4           org.kde.dolphin              vlc,1,3     0x00

I finally found the problem. Looking at the Flatpak permissions set me on the right track. I used Flatseal to look over permissions for GNOME Calendar, which is/was working and Evolution, which wasn’t working.

I noticed several permissions enabled in Calendar that were not there for Evolution. When I copied the same permissions over and reloaded evolution, calendar entries and contacts started showing up. It works perfectly now.

For future reference:

Use Flatseal to go to the Evolution permissions.
Scroll down to Session Bus and add the following names under the Talks section, which is right on top:


Thank you all for your help and suggestions here.

1 Like

This seems to be the latest post about this, so pushing it up.

Is there any process on flatpakking the GNOME evolution dataserver?

I think GNOME calendar looks awesome but it does not work on KDE at all due to the lack of this system component.

If layering works without many dependencies, I would consider that option as a temporary workaround, but would be interested in helping the packaging (if it works, regarding IPC or native messaging or whatever is required)

Even better would be updating akonadi and evolution dataserver to be interoperable, afaik evolution dataserver lacks maintainers?