Flatpak Evolution can no longer open attachments with an external program // how to debug?


For some reason that I’d like to debug and fix, I’m no longer able to open email attached documents by double-clicking them or by clicking “Open with default application” within the right-click menu.

I can’t see no error, nothing, even when starting the fedora flatpak application via the CLI, I don’t see anything either within the systemd journals (–user or –system).

I have no related permission overrides in ~/.local/share/flatpak/overrides
I tried passing –disable-eplugin when starting it, but same result.

I have no idea what to look for and how.

Any idea?

Many thanks in advance! :slight_smile:

(How do I work around the issue? → “save as”, then open the documents manually :expressionless: )

EDIT: forgot to say the system and flatpaks are up to date!

This may be partly due to the “sandbox” effect used to separate the flatpak from the main OS. Have you tried the ‘flatseal’ app to see what may be adjusted there for access?

Hello Jeff, thank you for your answer.

Yes I did try to play flatseal and with many of the available “overrides” (closing and re-opening the app every single time! :open_mouth: )

But the thing is that it used to work before (a few weeks/months back, don’t remember precisely) and that’s why I also tried resetting the app overrides to those shipped by default but it didn’t help.

I also reset org.gnome.Evolution permissions via flatpak permission-reset org.gnome.Evolution.

In the flatpak world, I believe the thing allowing an app to launch an other app is called the “portal”, but I don’t know much about it yet.

I would very like to have some error printed somewhere but just get nothing! Do you know how to make it more verbose in some way!?

Thanks again!

Which version of Silverblue, Gnome, Gnome Runtime and Flatpak evolution are you running?

Hello Joe,

Here are some information:

$ rpm-ostree status
State: idle
● fedora:fedora/37/x86_64/silverblue
                  Version: 37.20221110.n.0 (2022-11-10T08:01:16Z)
               BaseCommit: 90af8a249639b6116de1d81b0f04239a53bff61f49be8efdd0e0433ba1369e58
             GPGSignature: Valid signature by ACB5EE4E831C74BB7C168D27F55AD3FB5323552A
          LayeredPackages: aircrack-ng gnome-boxes gnome-tweaks gstreamer1-plugin-openh264 java-latest-openjdk kernel-tools lxc mozilla-openh264 neovim nmap openssl p7zip socat systemd-container tcpdump tmux virt-manager w3m wgctrl
                           wireguard-tools wireshark wl-clipboard

When looking in Settings → About → Gnome Version", it is said “Not available:thinking: This is interesting!
I remember the update to GNOME 43 (with the update to fedora 37 (beta) I assume), but I don’t know why gnome itself can determine in which version it is running.

As for “Gnome Runtime”, I don’t know how to check that, I grepped in “flatpak list” and in “rpm -qa”, but haven’t find anyrhing like this!

But I did find what appear to be some Gnome 42 left overs within the base system:

$ rpm -qa | grep -i gnome | grep 42

And also in the flatpak installed packages (but this may be a regular dependency):

$ flatpak list | grep GNOME
GNOME Application Platform version 42	org.gnome.Platform		42	flathub	system
GNOME Application Platform version 43	org.gnome.Platform		43	flathub	system

If you have any idea, I’m all ears!

Many thanks:-)

Can you check:
flatpak remotes

Do you still have the Fedora flatpak repo enabled?

flatpak info org.gnome.Evolution

Did this come from flathub or fedora?

My experience this morning was that:
Fedoras flatpak would not open attachments
Flathubs appeared to work fine.
The rpm version of Evolution appeared to work fine.

Created a but this morning 2142385 – Unable to directly open attachments from Fedora Evolution Flatpak

Still have the fedora flatpak repo configured and enabled and I’m also using flatpak evolution from this very repositiory.

And as you seem to face the same problem, I suppose there is not necessarily something wrong with my config/setup.

Thank you for the bug report, I will follow it closely :+1:

And just for the sake of completeness:

$ flatpak remotes
Name    Options
fedora  system,oci
flathub system

$ flatpak info org.gnome.Evolution 

Evolution - Manage your email, contacts and schedule

          ID: org.gnome.Evolution
         Ref: app/org.gnome.Evolution/x86_64/stable
        Arch: x86_64
      Branch: stable
     Version: 3.46.1
     License: GPL-2.0+ and GFDL-1.3
      Origin: fedora
Installation: system
   Installed: 138.9 MB
     Runtime: org.fedoraproject.Platform/x86_64/f37
         Sdk: org.fedoraproject.Sdk/x86_64/f37

      Commit: be3f3ad9c8dffc631370142b3a462d60656eebcf46936a0c32b9cd85dede7d35
     Subject: Export org.gnome.Evolution
        Date: 2022-11-06 22:46:27 +0000
      Alt-id: 88aa72769c1b96702f810166438ddb6b81aa5e9ab9bde31cc9d33f0aee4ff6b5

Cheers :slight_smile:

As a workaround you can install from flathub.