Reporting Bugs for Silverblue flatpakked Gnome desktop app's (Evolution 3.30)

flatpak

#1

Hello Team Silverblue,

I have followed Gnome’s instructions for flatpak ing Evolution to work with Silverblue. Yesterday, actually last night, I was closing out software before powering down my desktop. During the process I clicked on the top right window close button for Evolution and I got kicked back out to my login screen. What I am wondering is, should I report this to Evolution/Gnome or to Silverblue or Flatpak, and where do I file the bug in any case? If desired I can copy/paste the pertinent output of journalctl --user for the session.


#2

Hi, so what instructions did you follow ? And yes, I think that you should try to see if you can reproduce the problem first, because otherwise, it will be hard to figure if the issue is fixed or not.


#3

Hello,
I followed the instructions found here > https://wiki.gnome.org/Apps/Evolution/Flatpak

I cannot so far successfully reproduce it. When I look through the journalctl --user output I find just before the time of the session exit, it seems to have started when I closed Terminator, using the exit command. There is a warning from the window manager about the last_user_time being greater than the current time, and the offending window appears to be Z, which I take to mean zsh that I use in Terminator. After that the following message is displayed ‘Sep 21 00:27:03 localhost.localdomain gnome-session-binary[1572]: WARNING: Lost name on bus: org.gnome.SessionManager
Sep 21 00:27:03 localhost.localdomain gnome-session[1572]: gnome-session-binary[1572]: WARNING: Lost name on bus: org.gnome.SessionManager’. So I am thinking this may have more to do with my layered shell (ZShell) and layered Terminator. I’ll try closing out in that order and get back with results. Although I am always getting a vdagent spice error at boot up (shown in the log).

Update: could not get it to reproduce. I’ll need to leave it for a bit today as I have a service call to do this morning. I’ll try to set some tasks to run while I’m away from the desk.


#4

So, after I perused the user session log, I found that I also have issues with the Radeon driver not working correctly (libgl failed to load Radeon driver), which was followed by this error ‘Nested Wayland compositor could not initialize EGL’. Since it is likely due to the driver for my Radeon video card, I think I will mark this as solved until I can try the release version of F29 Silverblue. I did try the DRI flatpak, but adriconf causes a core dump every time I try to run it, without giving any indication it does so in Gnome. I only caught it by reviewing the user session log. In any case, no one answered where would be the appropriate place to file a bug IF I do find one such as I am mentioning. Any suggestions?


#5

How recent is your AMD GPU? If it’s one of the newer cards, you may need to add some parameter settings on the kernel command line and blacklist the radeon kernel module. The kernel is supposed to figure this stuff out by itself but sometimes you need to help it out.


#6

Hello
Thanks for the info, I’ll check it out tomorrow. My card is about 5 years old, so not likely one of the newer ones. Off the top of my head I’m not certain what particular GPU chip is on it, but I can say it is a lower end model, I don’t really need high end graphics for what I use my desktop as.


#7

Mine’s about five years old too. It’s probably a “Sea Islands” like mine. So either the radeon or amdgpu kernel module should work. What I’m not sure about is whether it’s a problem if both radeon and amdgpu are loaded. I think I saw that you shouldn’t have both but I don’t remember where I saw it.


#8

Mine is definitely a Saphire (brand name), and I think it is the 4xxx series of GPU if I remember correctly. I’ll try the black listing.


#9

So, it would appear that I am more or less the creator of my own issues. During my installation of F28, I was a bit rushed in my approach to the system setup, and should have spent a bit more time digesting the information provided. What I have unfortunately done through the run of the F28 install, then the rebase to F29 and subsequent flatpak installation of the various apps I normally use, ended up with some things getting installed as user and others I did as sudo (old habits die hard). This led to me thinking I solved issues to get the flatpaks installed, which was apparently true at the time, but is largely a headache when updates come down the pipe. For instance, org.freedesktop.Platform.ffmpeg/x86_64/1.6 is required by various flatpaks I installed, and I did/do have that installed as a user. I have Vim installed as sudo, consequently when software notifies me that Vim has an update I cannot update via the Gnome Software as it always fails for me. I go to a terminal and do the update for vim (as sudo because it fails otherwise), I get a 404 error for org.freedesktop.Platform.ffmpeg/x86_64/1.6 updating. If i go to update org.freedesktop.Platform.ffmpeg/x86_64/1.6 as user, it comes back with nothing to do, no errors, etc… That is just one example, and for me it highlights the necessity to review the documentation thoroughly on how to set up an ostree+flatpak system. This is of course, irrespective of the topic I started, but I cannot help but think I did some of that to myself in the general excitement to get this new workstation version going. Is release date on schedule to align with the normal Fn Workstation release cycle?


#10

Hi @jakfrost,

To answer the initial question: bugs would be filed here for now: https://pagure.io/teamsilverblue/issues

Cheers,
sanja


#11

Thank you Sanja,
Best regards
Steve


#12

Evolution got official -> https://github.com/flathub/org.gnome.Evolution
Just an FYI.


#13

Hello,

Yes thanks I noticed that. I had done the roll your own flatpak following the instructions given by the Evolution Team. The problem with that approach is no updates without manual intervention…