Share screen on Cisco Webex using Firefox

I’m using fedora 34 and previously fedora 33 with gnome wayland and we use Cisco Webex at work.
I’m trying to share my screen on Webex using Firefox and although it seems that it’s working (the share icon is on the gnome topbar and webex shows the previous snapshot), my collegues can’t see my screen.
If I use google chrome I can share my screen enabling the pipeware flag using wayland and without any flag using Xorg.
I have tested on firefox with Xorg and the problem is the same, it seems its working but it’s not.

I have enabled the rpm fusion with the mozilla-openh264 plugin.
When my collegues share their sceens I can see them perfectly so It seems this is not a h264 plugin problem.

The thing is that using Debian Bullseye with gnome 3.38 it’s working with the firefox version downloaded from with wayland and Xorg.
I have tested with firefox version downloaded from and is not working either.

Any ideas?

Thanks in advance.


Can you also test with the flatpak version of Firefox?

Same problem here, Flatpak doesn’t work either.

1 Like

@srgcdev Can you go here, in the “getUserMedia example” click on “Try Demo” and see if screen sharing it’s working?

1 Like

@sampsonf, I have tested the Flatpak version and doesn’t work either.

@johnnyjuki, I have tested the mozilla demo page and it’s working properly with both wayland and Xorg. I also did a test with and works well too.

I can add: In Webex, the small preview on the bottom of the screen also works. The video just doesn’t get sent.

I believe the difference between Jitsi Meet and Webex is that Jitsi defaults to VP8, while Webex (only?) uses H264. Is there a good testing page that can force H264?

It seems it’s a problem with the workstation edition because I have tested with a Fedora minimal installation from the server edition and then install xfce desktop with:
dnf group install base-x xfce
dnf install firefox
And then following this guide:

It’s working well.

Actually I just tried it on my laptop with a live usb stick: Workstation edition works after installing mozilla-openh264. So maybe there is a conflict with some rpmfusion package?

@cpl, I have did a fresh install in a vitual machine, update packages without install any rpm fusion package.
Then follow this guide:

The package mozilla-openh264 is already installed in my case.
And it’s not working.
It’s weird.

Just did the same thing, and it worked until I did a dnf up. This updated a bunch of packages, pipewire, specifically pipewire-gstreamer looks a bit suspicious.
Did you update your minimal installation before trying?

@cpl My minimal installation is up to date.
I have installed the suspicious package pipewire-gstreamer and it is still working.

I “bisected” the updates in a VM and arrived, of all things, at the update from gnome-boxes 40.0-1 to 40.0-2. This pulls libvirt-daemon-config-network, which just writes

<bridge name="virbr0"/>
<ip address="" netmask="">
<range start="" end=""/>

to /usr/share/libvirt/networks/default.xml

I really don’t understand what is happening here, but I guess this IP address might conflict with WebRTC somehow? This file is also present on my Fedora 33 install, so it’s not that simple.
Anyhow, try uninstalling libvirt-daemon-config-network and rebooting afterward, (maybe dnf donwgrade gnome-boxes first if you want to keep that) because that did it for me.

1 Like

@cpl, I have just installed gnome-boxes on my minimal installation with xfce and now it is failing too. So yes, It seems that the configuration on ‘/usr/share/libvirt/networks/default.xml’ you mention is causing the problem.

1 Like

Do you have addon in Firefox like uBlock Origin?

If so, can you try to deactivate them for CISCO WebEx and try again?

See here

@johnnyjuki, I have the ublock origin addon on my firefox and It’s working well if I have gnome-boxes uninstalled. Like @cpl mention in a previous comment, the problem seems to be related with a configuration on libvirt.

If this is unexpected, could you please file a bug so that the maintainer can look into it? I don’t see one filed yet:

Libvirt bugs on Fedora Bugzilla

Some information on filing bugs is here:

Was a bit short on time, lately, but I just did: 1958358 – libvirt-daemon-config-network/virbr0 breaks Cisco Webex screensharing

1 Like