Some web video not working - Fedora 35 Silverblue

Recently rebased to Fedora 35 and updated and since then some of the online video in Firefox just doesn’t work.

It was working just fine in 34.

I have mozilla-openh264 as a layered package and ffmpeg and ffmpeg-libs installed through flatpak.

This was enough in 34, I didn’t need rpmfusion enabled at all.

Is possible to get this working well with only free software?

See if you can try to determine specifically which codec isn’t working on which build of Firefox. You mention both layered and Flatpak but in my experience it best to go the whole distance one way or the other as it pertains to the browser. Meaning go Flatpak and/or get all the layered packages you want/need.

Three possible options for Firefox… layered, Fedora remote, or Flathub remote. Layered will use local codecs like the h264 and ffmpeg packages, Fedora uses the org.fedoraproject.Platform runtime, and Flatub uses the org.freedesktop.Platform runtime. Fedora’s runtime comes with a lot of GStreamer and Vulkan goodness but do not have some of the fringe software like ffmpeg, which is an extension for the freedesktop runtime.

1 Like

At the moment I switched to the flathub version of firefox directly from Mozilla and it seems to be working fine. I uninstalled the RPM ostree one so I don’t accidentally open it instead. I worry I might not be able to update my gnome-shell extensions though.

I have the extensions flatpak installed for managing the installed ones, but there is also the cli gnome-extensions
help Print help
version Print version
enable Enable extension
disable Disable extension
reset Reset extension
uninstall Uninstall extension
list List extensions
info Show extension info
show Show extension info
prefs Open extension preferences
create Create extension
pack Package extension
install Install extension bundle


From @jakfrost suggestion: Flathub—An app store and build service for Linux

Is it possible to update existing extensions entirely from the flatpak, if I remember correctly trying to do so just opens it in the browser.

That could be true for updating the actual extension(s), but not for adjusting extension settings which is what the Extensions flatpak seems to be about. I would think that you can also use gnome-settings to assign the default browser to another one if you are not using the preinstalled FF or prefer a different one, at least it makes sense to be able to.

1 Like

Maybe I should reinstall the default one and figure out a way to hide if from the gnome shell menu… or maybe I could even rename it