Firefox wont play videos

I switched some weeks ago fully degoogle qnd started to use firefox, but i am getting huge issue for now i can olay 80% of videos using youtube website, on all embedded youtube and study/course material i cant play i get errors only and on debug view i see cookies and pkayers are getting restricted and not accepted since notbon this country statments. I tested google flatpak and all videos works on it that dosent work on firefox

couldent get anything work so just installed brave flatpak and now all content and video works

Added f40, silverblue

Some questions to help diagnose:

  1. Are you using the Firefox RPM?
  2. If you’re using the Flatpak, are you using the Fedora Flatpak or the Flathub Flatpak?
  3. Did you install the codecs from RPM Fusion?

Go to about:support in your browser and find the Codec Support Information section. This should give you some more clues, though it’s actually displaying incorrect information for me right now…

1 Like

It is what fedora ships by default on silverblue
And on about:config is pretty strict tbh honest iy just had these issue on ff 126 and now ff 127
I will add screenshot on config when i am back to laptop to get more about how strict it is now days

The version of Firefox that ships with Silverblue intentionally disables H.264 support. It can’t play H.264 videos. Usually YouTube falls back to AV1 or VP9, but it seems to serve H.264 when it’s embedded based on what you’ve said.

Here’s what you can do if you want to playback H.264 video:

  1. Layer on openH264 with rpm-ostree and you can continue using the Firefox Silverblue ships by default.
  2. Install the Firefox Flatpak from Flathub. Do not install the Flatpak from Fedora Flatpaks, which also does not have support for H.264.

Well this is again something that should be done by default from fedora silverblue team since itbis again preventing normal usage so why those are not done by default already and if it is licensing issues why even use firefox by default

I agree, but that’s patent law for you, unfortunately.

Patents prevent Fedora from shipping H.264 support in any browser; it just so happens Fedora chooses Firefox as the default browser. Nothing would change if they chose Brave or Chromium instead.

Fedora does make the situation worse by not including openh264 by default. This would have allowed you to playback H.264 videos in Firefox without needing to do anything. The reason for this is that Fedora is only allowed to use openh264 in binary form for the royalty-free license to apply. If they build openh264 themselves, they’re open to a lawsuit. Because of Fedora’s principles regarding free software, it is not included in the default repositories and openh264 must be installed by the user’s choice.

I made a thread about this two months ago and got some interesting responses, if you’re curious about the exact details of the situation: H.264 Support in Fedora Workstation (by default)

Oh, and if you’re curious why Flathub repositories are enabled by default and H.264 playback is allowed in Flathub packages, uhh see this article by LWN?

yeah but there is also fedora quality agreements that all apps shipped by default should work out of the box without any issues so this is conflicting as someone installing example Silverblue and opens FF start browsing and sees only netflix and youtube works with fallback and DRM enabled, but all other is just out of the work so how this fits Fedora set rules how things should work by default

by default apps should be in that state that user do not to start trouble shoot or layer additional drivers to start using

The situation is the same on Fedora Workstation, and it’s been like that since the 2000s. What has changed is that Fedora (along with openSUSE) disabled hardware decoding for H.264 and H.265 in 2022. Before then, users with a compatible GPU would have been able to playback H.264 media “out of the box”. Now you must install the hardware acceleration drivers and codecs from RPM Fusion or Flathub.

Fedora would very much like to change this situation, but they can’t legally do so.

Note that I’m not associated with Fedora in any way aside from as a user on this site. And occasionally I report bugs. I don’t think anyone actually associated with Fedora would tell you any different, though.

if they dont and cant change this due the limitations i think it would be better to not ship any browser by default and let user install browser they want by flatpak or rpm. That would be much more effective way to not get stuck on this loop for new users etc

This is an ongoing discussion:

H264 Video playback out of the box

  • Solution: klember is creating a specially crafted Flatpak extension that would download and copy the openh264 files from Cisco - currently planned for Fedora 39

(Clearly this did not happen in Fedora 39)

It doesn’t solve the situation by default, but it will at least be easily fixable by installing a Flatpak extension through GNOME Software.

I’m not sure what the official position is on removing Firefox from the base image as a solution.

By the way: Firefox includes OpenH264 support by default and automatically downloads/installs it. Fedora explicitly disabled it and prevents the auto-download process inside of Firefox, forcing you to layer a package to let you install OpenH264 in Firefox. If they stopped doing that, that would also work.

2 Likes

The licensing that prevents the openH264 being included has nothing to do with firefox and everything to do with that codec which comes from cisco.

Fedora cannot directly distribute that codec, though by arrangement with cisco they do make the codec available at the fedora-cisco-openh264 repo.

Well, Fedora is a GNU distribution of Linux. To explain that, would be to go down the Free Software Movement and the Concept behind FOSS/FLOSS and OSS.

The problems you are having were the same I had almost 15yrs ago, but as time passes and you shape your build and workflow, it will become “The way to do things”. Yes, you need patent encumbered codecs to play 90% of videos, and to view other content, but this fall back on GNU. It’s your right to choose to do so or install it yourself.

I know you are new to Linux in a way, so understanding these principle can seem out of the ordinary, but Fedora exist in a world where choice is the Ordinary.

To overcome your issues, you need to have the Third pary Repos set up, and the more you reinstall Fedora, the more customized your builds become, you will have scripts to do all of this yourself ! :fedora:

These are minor pain points, but it’s better thean the default we see in the world today :fedora:

i know these pain points most of them and yes i am new on silverblue atomic ones as daily main and the difrence is night and day tbh on workstation and silverblue. on workstation i didint see ff video play issues, but silverblue i see them. there are some other small things too, but at the end question was why to ship product/products that need to instantly make so much efforts and layering codecs/packages on atomic? this was the point it is like making cake and half paked only and then you need to pake it more or eat it.

also less you layer the better is the base system on long run thats why i have been exerimenting and moving lots of apps to difrent ones with appimages/flatpaks to reduce layering and same time trying to keep system as stock as possible to fit on my workflow and needs.

the journey is always learning and testing yes and someday everything fits and you have scripts to setup all instantly that is the goal on atomics too.
what i have seen that appimages actually work so much better on most cases than flatpaks on atomic enviroment and brave flatpak has PWA rules enabled automatic no need to mess with flatseal to enable PWA icons and desktop startups

this i do so man times i think i have reinstalled workstation way too man times that i can do it eas with m eyes closed with nvidia drivers installed and all basic apps and settings done less than 30 minutes. Silverblue getting there and same still learning the quirks and hoops, and trying to understand more of the apps, codecs and licensing stuff

wait what has been changed since my other laptop has silveblue 39 and FF all videos works on the sites no issues, but F40 Silveblue not working

Can you try rpm-ostree status on your f39 Silverblue laptop?

i can old version havent booted it up for months version is still 39.1.5 and this is all Intel based system no amd or nvidia

It doesn’t matter what GPU you’re using; H.264 decoding just isn’t supported in Fedora by default, no matter the version.

The only change made was 2 years ago when hardware decoding was removed: The disabling of hardware codecs in community distributions [LWN.net]

Before then, Intel and AMD users could probably playback H.264/H.265 media with their hardware decoders for several years. So yes, there has been a major regression, but it happened years ago.

Fedora 39 is far newer and should not let you play H.264 media by default. It’s likely you layered on an extra package like openH264, or installed Firefox via Flatpak instead.

no layers it is just stock default stock image not even updated after installation

Okay, let’s test it. I can’t play this video in Firefox 127 from F40 Silverblue because it’s H.264: KDE & GNOME have BIG plans, OpenAI investigated for GDPR breach: Linux & Open Source News - TILvids

I can play it in Brave Flatpak because it has H.264 decoding support.

Can you play it in your Firefox from F39 Silverblue?