Not able to share screen with Jitsi meet on Wayland with Flatpaks

Same here. For me it doesn’t work with Flatpak apps (Firefox and Meet). It works as expected with Firefox from F33 repository.

1 Like

Ah, that’s worth checking. The Flatpak apps need permissions, so that could be one place to look. Additionally, unless the Flatpak is from the Fedora registry (which means it was generated from the rpm in the Fedora repos), it may have other bugs in it—one will have to speak to the people generating the Flatpak in this case ( for example).

I see. But there is no Meet Jitsi in Fedora repositories. Too bad. For now I’ll use it in repository based Firefox, where it works. Thanks

If it works in a standard browser, that indicates it’s an issue related to the Flatpak.

I’d file a ticket here so that the provider can check what’s up with the Flatpak:

The app is just the web bits bundled together in an Electron application from the looks of it. No clue how that may affect screen sharing with Wayland etc. though.

@t0xic0der : is this discussion relevant to you, otherwise we should split the topic into a new one for @lapor .

1 Like

@lapor : please edit the title and description as necessary here :slight_smile:

Thanks, I’ve edited the title. I am also adding this conversation on issue report on Github:
I guess Fedora has to merge patches to upstream, for Electron apps to work normally on Wayland/Flatpak/Fedora :slight_smile:
But there is also issue with Flatpak Firefox. It is also impossible to share screen…

1 Like

I can share my screen without any configuration on Fedora 34 Silverblue on Wayland. This is thanks to feat(linux): enable PipeWire support for screensharing by csett86 · Pull Request #584 · jitsi/jitsi-meet-electron · GitHub on the Jitsi side, and Add pipewire 0.2 for Electron · flathub/org.jitsi.jitsi-meet@63f9a41 · GitHub on the Flatpak side.

1 Like