Screensharing problems in the Firefox flatpak after upgrade to Fedora Silverblue 34

I recently upgraded to Fedora 34. It seems screensharing from the Firefox flatpak stopped working in the process.
If I share my screen from either Bluejeans or Google Meets, I get the prompt in Firefox, giving me the choice to “Use operating system”, after that it gives me a Screen Share screen from the OS. If I select the monitor, nothing else happens and other people in the call can’t see my screen being shared at all.
It works as expected in the non-flatpak Firefox.

Now I’m trying to figure out what component broke, so I can file a bug. Is anyone else seeing this behavior? Can anyone verify this happened to them as well with the upgrade to F34, or was it an update to the Firefox flatpak that just happened at the same time?

I’m having the same issues here on F34 also.

Here are the issues when @andreasn and I each tried it, in combinations of Flatpak and native, for both Firefox and Chrome, in Google Meet and BlueJeans:

Flatpak

  • Firefox doesn’t share the screen
    1. Firefox “Select window or screen” is preselected, and doesn’t work
    2. One must choose “Use operating system settings”
    3. Telling Firefox to remember it, says it cannot remember
    4. GNOME shows that the screen is being shared (red icon in the top-right on the primary screen), but there’s no other indication that the screen is being shared… because it probably isn’t.
  • Chrome shares a black screen

Non-Flatpak, Fedora package:

  • Firefox works
  • Chrome has… issues, but eventually works
    • it has to be accepted several times:
      1. in-window Meet selection
      2. in portal
      3. Chrome has a selection confirmation w/ thumbnail
      4. then the portal selector pops up again
    • In BlueJeans, Chrome skips everything but 3, but the screen is black (everything else in BlueJeans is the same as Google Meet, detailed above)

I think there are problems across all the software involved and everything probably needs fixes: Both browsers (especially upstream in Flatpaks), Flatpak, the screen sharing portal, and possibly PipeWire in some cases.

Some of the issues above prevent screen sharing from working altogether. Some are just really weird UI issues.

Edit: @andreasn filed an issue in the Silverblue repo @ Screensharing in Firefox flatpak stopped working after update to Fedora Silverblue 34 · Issue #159 · fedora-silverblue/issue-tracker · GitHub

Here’s the screenshot of Firefox’s popup where the selection is “Select window or screen” by default. However, it doesn’t work. You have to click on the dropdown and see that it’s actually disabled. Then select “User operating system settings”.
Screenshot from 2021-05-03 13-18-19

When you try to tell Firefox to remember it, you get this red error text:
Screenshot from 2021-05-03 13-17-45

For flatpak, using the application called flatseal, check if your browser has the right permissions.

Under the section Filesystem and subsection Other files check if the following shows:
xdg-run/pipewire-0

If not, add it and see if this fixes your issue.

Use the following button to add the permission:
image

2 Likes

Thanks, that did the trick!