Chromium issue: unable to view screen shares in teams web app

I have to use ms teams for work, and the best way to do this up til now was to use the web app through chromium. Previously I was using chromium-freeworld from rpmfusion and this worked fine, but with the upgrade to F38 chromium-freeworld appears to have gone byebyes as it’s unsupported or retired or something. Anyway long story short, using repo chromium I am unable to view screen shares from ms teams or share my screen. I have force enabled the webrtc-pipewire-capturer flag in the browser and set some enable flags in the startup but it hasn’t made a difference. Anyone have a solution? As a workaround for now, I am using the google-chrome flatpak which is functional, but ideally I would prefer to use the rpm. Note I am using KDE Plasma on wayland with Fedora 38

CommonBugs - RPM Fusion

With the Fedora chromium package now using codecs from the system ffmpeg available at runtime, RPM Fusion counterpart package is now discontinued. Please use the Fedora chromium package.

sudo dnf swap chromium-freeworld chromium

Yes, it looks like you are not alone:

I have already removed chromium-freeworld.

My main issue is that I now cannot participate properly in ms teams meetings using the installed version of chromium from Fedora repos, whereas I could previously before I removed chromium-freeworld, because when someone is presenting I get no output from them.

I have already tried replicating the same flags that chromium-freeworld was using with no improvement in my meeting quality. Me sharing my screen is something I do very seldom, but viewing other people sharing theirs is extremely important.

While I can use the flatpak, and I had already seen the post you mentioned above (which references an older version of chromium) I would rather use chromium proper so I can have proper integration of my webapps with Fedora.

If chromium proper installed on my system is now using the exact same codecs as chromium-freeworld, what is preventing the shared screen/video output from being displayed?

Just enabled Vulkan for hardware rendering, and enabled a few flags to ensure video acceleration is as optimal as possible, will see how teams goes for a bit, for anyone interested the chrome://gpu report is:

edit: this also made no difference to ms teams…

edit 2: If it makes any difference I am using the nouveau driver, but as mentioned it worked fine until I removed chromium-freeworld