Right click of touchpad does not working

In my lapi i find that right click function is not working on the touchpad but on my pc if i do right click on a file i get other options but here nothing happening how to enable that my i am in fedora workstation. Lapi and pc both.

As a start look at the hardware and software on both machines. I would suspect that the touchpad on the laptop is matched by a mouse on the PC and that means different drivers, etc. Comparing apples & oranges is counter-productive.

Detailed info from the machine where things do not work is needed.

Which laptop do you have? I guess you have to click an additional key as FN or similar to get the right click.

1 Like

Click touchpad with two fingers for rightt-click and three fingers for middle-click


Yes right but the manual switch is not working from touch pad i have twosides to click but left is working but right one is not.

There are many types of touchpads. Some of them are called multitouch. On those You can use two finger tap for right-click, and three finger for middle-click. You must enable this using gnome-tweaks. If You have older type (as it seems from Your last post), and one of “buttons” is not working (usually located on lower part of touchpad), it could be hardware problem on touchpad, or some misconfiguration issue (maybe driver).

This was not an issue in kde or xfce on in gnome both right and left register left and double tap register right is it default in gnome for all. Or it is specific for me.

that’s by design as said by @ledeni in post #4

tap/click with one finger on the touchpad (no matter where on the touchpad): left click
tap/click with two fingers on the touchpad (no matter where on the touchpad): right click

Yes thanks i was using kde in lapi so don’t know about it there right click is and left click works same as mouce clicking right and left so on switched gnome so don’t know about.

You can select different touchpad behaviour in Gnome Tweaks

You can achieve the same in following instructions here: https://www.reddit.com/r/gnome/comments/nvcqtx/gnome_40_enable_right_click_button_on_touchpad_of/

No thats okey anyways thanks for help.

Please do not use text speak or idioms when referring to specific devices. I think most of us understood you meant laptop with that word but many will likely not recognize that.

This is similar to a nephew of mine that talks about using ‘Crafty’. (Did you understand that he meant a Craftsman mower?)

Lapi and laptop also do not instantly describe the same thing.

Sorry for that but actually i use and speak like that so mistake happened i will be more careful sure about that.

simple need enable Areas!

gsettings set org.gnome.desktop.peripherals.touchpad click-method ‘areas’

You need to change the touchpad clickarea method.

This can be done via gnome-tweaks, or on command line first type

gsettings list-recursively org.gnome.desktop.peripherals.touchpad

to see all options. To see current click setting type:

gsettings get org.gnome.desktop.peripherals.touchpad click-method

To see options, type:

gsettings range org.gnome.desktop.peripherals.touchpad click-method

To change to right click method, type:

gsettings set org.gnome.desktop.peripherals.touchpad click-method ‘areas’

Original post by NaheemSays