How to enable the mouse functions of the touchpad?

I assume that nowadays, every touchpad of a laptop has got mouse functions. My touchpad has got no buttons as mouse buttons. It only consists of one single area. At the moment, I’ve got enabled ‘Tap to click’. I can only do ‘left clicks’ but no ‘right clicks’. Mouse keys - Wikipedia doesn’t work, at least in Firefox.

How can the standard mouse functions or ‘buttons’ for ‘left clicks’ and ‘right clicks’ be enabled?

Hello @coffee ,
There are mouse and touchpad settings in Gnome Settings, but I am uncertain as to the backing app/driver/mapping of the device. It can likely be found using lspci since it’s likely on the PCI bus.

I have a razer 2020 laptop and on its touchpad also pressing does not work only scrolling. It is a good thing that at least there is an option to disable it at all - I use only mouse.

I believe tapping with two fingers should make for a right-click, and tapping with three for a middle-click.


Thanks. Right clicks work when tapping with two fingers.

@mattipulkkinen How can I highlight or select text?

Try a single-finger double-tap-and-drag.

1 Like

I don’t understand. I mean how can I highlight or select not only one word, but for example a whole paragraph. Usually, I’d put the mouse pointer to where I’d like to start highlighting, press the left ‘mouse button’ (if I had one) and keep it pressed, move the mouse pointer to where selecting should stop and release the ‘mouse button’.

Try to not press, but double-tap-and-hold. It’s difficult to explain in text.


Ah, I see. Double-tap at the start, hold and move to the end. Thanks.

By the way, is it a frequent problem, that ‘mouse buttons’ of touchpads don’t work in Fedora?

I would wager that it’s a pretty uncommon problem.

1 Like

@mattipulkkinen Is it possible to make the standard mouse ‘buttons’, which I assume to exist on the touchpad, work without the diversions via ‘Tap to click’?

Does the touchpad not have physical buttons? Does it ‘click’ if you press down on the pad? Some touchpads don’t have physical buttons at all, so it would be best to make sure that yours does.

If it does, then I don’t really know what’s going on. There could be a BIOS option that disables them, or there might be a hardware switch that activates by double-tapping one of the corners of the pad. Outside of that, my guess is that it’s a driver issue, in which case I don’t really know if there’s anything that an end-user can do.

The touchpad is only one single rectangular area without any visible buttons. I assume that the lower part of the touchpad corresponds to the mouse buttons. When I tap in the centre far left and at the bottom left, it doesn’t do a left click and when tapping in the centre far right and at the bottom right, it doesn’t do a right click. On my old laptop, there were physical (hardware) left and right mouse buttons and when I’ve been pressing them, I heard a click sound and felt a resistance. This is not the case with the touchpad of my new laptop. It seems to be fully eclectronic.

As far as I remeber, there are no touchpad settings in the Bios and I strongly assume that no hardware switches are built into the touchpad.

Left click should correspond to the bottom left area of the touchpad, right clicks are usually two-finger actions along the right side of the mousepad. If you have a user manual for your laptop it should explain this.

More modern touchpads (some business Dell models) handle these functions with gestures, how you glide over the touchpad can potentially highlight areas of text, or even scroll up/down a web page. This is purely a touchpad topic, your Gnome desktop settings would mimic this functionality. Consult the laptop manual or make/model website for more information on this.

1 Like

This sounds like the issue I have had each time I have put Fedora onto a new laptop.

To get it working the way I want (which it sounds is the way you want) I installed Gnome Tweak Tools (and Why is not that a standard part of the initial install?), and went into the section dealing with the touchpad, where the options you want should be available.

It won’t help with tactile feedback, I’m afraid, as that’s a matter of physical construction, but should sort out the rest.

“Tweaks” is a GUI for GNOME options which are not part of intended user experience and which are mostly not supported by upstream developers. If you are unable to work with the hardware (and it’s not personal opinion but objective fact) without changing something in “Tweaks”, then this may be a bug.

For example: in context of “tap to click” option lastly there was a change in GNOME code repositories to enable this by default. This will land probably in next Fedora release. peripherals: Enable tap to click by default (!71) · Merge requests · GNOME / gsettings-desktop-schemas · GitLab

1 Like

I welcome this, because I haven’t even been able to install Fedora without connecting a mouse, because ‘Tap to click’ hasn’t been enabled by default.

1 Like

Tap to click:
gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true

To see what it is set to:
gsettings get org.gnome.desktop.peripherals.touchpad tap-to-click

Left/Right Click:
gsettings set org.gnome.desktop.peripherals.touchpad click-method 'areas'

To see what it is set to:
gsettings get org.gnome.desktop.peripherals.touchpad click-method

It defaults to fingers (two finger right click)

This can also be set in gnome-tweaks as others have mentioned.

I read the paragraphs regarding the touchpad in the user manual of my laptop. According to the user manual, the lower part of the touchpad does not correspond with the mouse buttons. Apparently there are no mouse buttons. Left clicks are done by tapping with one finger, double clicks by double-tapping with one finger and right clicks by tapping with two fingers (with all tapping operations, it doesn’t play a role, where on the touchpad they are done). Without enabling ‘Tap to click’ almost nothing works.

@hamrheadcorvette Thank you for pointing me to the user manual.

@mattipulkkinen Because I didn’t know how to do right clicks and highlight or select text, and you told me, in my opinion you solved the problem.