Bottom right corner of trackpad not working for right click

I recently picked up a Lenovo X1 Carbon Gen 10 and I am dual booting Windows 11 and Fedora 37. Pressing down the bottom right corner of the trackpad works as right click in Windows but not in Fedora. It seems to be the only big hardware functionality difference between the two operating systems at least from what I can tell so far.

Any advice on a potential resolution to get that working in Fedora 37 as well would be greatly appreciated!

If you are using Gnome desktop:

  1. click Activities (upper right corner of screen)
  2. type: trackpad
  3. click on the bubble with Settings…trackpad
  4. fiddle with the controls on the dialog and see if that helps you.

Hey, thanks for the reply. This was my first thought as well and unfortunately I don’t see anything under the Gnome trackpad settings that enables this specific feature.

Can you check gnome-tweaks,
Should be under keyboard & Mouse under Mouse Click Emulation → Area

That did it, thank you!

Thanks for posting that. I was struggling with same exact issue and Gnome-tweaks worked for me as well.