Registration difficulties on

Looking at Getting Help :: Fedora Docs it says is the official chat platform Fedora, and I thought I would try to join there using my Fedora account.

However, I can’t work out how the consent procedure is supposed to work. I can log in and get a message with various links, but none of them offer any way to actually signal consent, by buttons or otherwise.

Should I take this to mean the platform is not actually ready for public use and I would need to get a Matrix account elsewhere to join (or stick to the channels bridged IRC, like I do now?).

Hmmm — can you post a screenshot of the problem you’re seeing?

Video: Nextcloud

Update: sorry, this was the first time using the new built-in screen recording in Gnome and I missed the “show pointer” button. I hope it is still clear enough, otherwise if it wasn’t clear, basically I’m following the links to review the various policies, but can not find anyway to complete the consenting procedure.

Here is the invite to the Fedora Matrix space, which should link you to all the chat rooms in the project. From there you should be able to find and select the ones you want to join.

When I first signed in with my Fedora account it automatically added me to the Matrix space and slotted me into a few rooms. I’m not sure what happened that it didn’t work for you. :confused:

I get the same result trying to connect that external instance of Elements to the Fedora home server.

I tried DMing you an invite through Element instead of just using the invite link. It will be from

The only other thing I can think would be to try joining the chat room individually for now, joining should work like it would for any other Matrix account. However, at this point it seems like a bug or something to me.

Thanks for that attempt, I’m afraid clicking accept on the invitation gives me the same popup as trying to join myself.

That’s unfortunate; sorry you’re having issues. At this point I can only think of workarounds like making a non-Fedora related Matrix account (which is also simple) and trying the invite that way or joining each room individually, and even then I’m not sure if it would work.

This may be unrelated, but maybe depending on when you created your Fedora account it could be causing it? That’s a total shot in the dark though and it’s probably not that. I only think of it because I know there was something else (badges I think) that had a problem along those lines. I made my account this week so ¯\_(ツ)_/¯.

I’m going to post this in the Matrix meta channel and see if anyone there can help.

This may be unrelated, but maybe depending on when you created your Fedora account it could be causing it?

No, that’s probably it, the links mentioned in the modal dialog point to this being a policy introduced at some point, and I guess people that had accounts before then were grandfathered in?

1 Like

I think it’s maybe the other way around because I made my account like 2 weeks ago and had no problems. I wonder if accounts old than a certain point are seeing these issues. But also no one else has mention this I don’ think.

Aminda in the Meta Chat channel wrote:

I wonder if it could be a case of adblocker or something and if using a “native” client outside of web browser like Element ( im.riot.Riot ) from flathub could help

I had no issues logging on this instance a few days ago (other than resolved default name) and my Fedora account is from 2012 or early 2013

A few others also recommended try native clients. Nheko, Neochat, and Fractal were suggested. I’m not familiar with those because I like sticking with Element since it’s created by the people who develop the matrix protocol.

No luck. Fractal doesn’t seem to support SSO login at all. With Nheko, it lets me login through a browser window, but then it shows this message:

This is the same url that redirects me to the terms and conditions page as from the web client, with no way that I can find to “accept” the conditions.

With Elements I get similar results as with Nheko.

I’ve also tried both Chrome and Firefox out of the box with no special configuration or addons.

I’ve also read that conditions page several times from top to bottom in case there was some hidden smallprint on how to consent to the terms.

PS. Don’t know how to check how old my accunt is, but I vaguely recall I created it during 2019 after starting to use Silverblue.

I guess the idea is that this page with a magic token in the URL should either just record that I’ve viewed the document, or that page should have some button for me to click accept?

Either way, it seems bad that Getting Help :: Fedora Docs points to this chat platform, but going there, people can not actually sign up to use it. I would report it as a bug, but I also couldn’t find an appropriate category for it at

Wider Fedora community - do we get any support from New Vector for our Matrix instance?

It seems like most folks are able to get in, but even so this bug should be dealt with. It sounds like it’s frustrating to be handicapped in how much of the community you can interact with.

However, I think most if not all the matrix channels should be bridged to IRC, so I guess you can continue using that in the meantime. I’m not familiar with IRC, but if you can find your way to the chat room, you may be able to get quicker help through there.


I couldn’t find that channel bridged to Libera.Chat, but I did find #fedora-commops, so I’m trying to find someone responsible through there.


That’s a very odd one—It does look like something new that’s been added. @mattdm would you know if something’s changed recently? I saw the video and there’s no way to accept the T&C after reading it all.

@bkhl I assume clicking “dismiss” didn’t do anything either?

Correct, clicking dismiss closes the dialog without joining the channel, and it appears again if I try to join a channel again.

1 Like

I think we’ll need to wait for @mattdm to maybe take a look into this.

I currently have two accounts that I use to access the Fedora channels. One is on the Fedora homeserver, linked to FAS, and the other is just linked to the Element/Matrix default homeserver. Do you want to check if the latter works for you in the meantime? I think one logs in from the “normal” element homeserver app, and then follows the same process to find rooms but in the fedora homeserver.

Sorry, this fell off my radar. I’ll send it to Element support and see what they can figure out.


Clarifying question: @bkhl (or anyone else) — does this problem happen using the Element web client at, or only when using a client program?

1 Like

It happens in the web client in various browsers as well as a few desktop clients I tried.

If you want the full list of things I tried, scroll back to Registration difficulties on - #11 by bkhl