Recent update breaks graphics on fedora 39 running under Windows 11 with VMware 17 Player

I run fedora 39 under Windows 11 using VMware 17 Player and have been doing so for quite a while. Around December 16th after doing a “dnf upgrade” , the login screen comes up with some of the graphical elements messed up or with the entire sceen very faint. After clicking on it with the mouse, the screen will go completely dark and I can’t get any response from it after that. This happens in both Gnome or KDE running with Wayland or X11.

After much messing around and reinstalling, I finally figured out that enabling “Accelerate 3D Graphics” in VMware for the virtual machine is what was causing the problem. If you turn it off, fedora runs fine.

I also have VirtualBox installed, so I decided to try running fedora in it to see what would happen. As it turns out, if you have “Enable 3D Acceleration” turned on under VirtualBox, fedora will fail in the exact same way as it does in VMware. If 3D acceleration is turned off, it runs fine.

Has anyone else seen this or might know what package{s} broke it? I don’t know if this is a fedora issue or a VMware/VirtualBox issue.

I am not sure I understand the situation.

Are you running F39 under 2 different VMs on a windows host? One with VMWare and one with VirtualBox?

If so this seems related to either windows itself or to the way graphics acceleration is managed between the VM manager and the host GPU driver.

On a system where F39 is running directly on the hardware graphics acceleration works perfectly for me.

I would also note that even with a VM running fedora on a fedora hosted machine it seems not possible to use true graphics acceleration unless there is an extra GPU installed that can be directly passed into the VM so that the OS of the VM is using its own drivers to manage the hardware acceleration.

I would not know what may have been changed with your update, you would need to check what packages were changed, but I would suspect that this is related to interaction between the kernel drivers and the graphics of both VMware and VirtualBox. Was windows updated at about the same time?

Windows 11 Host machine , VMWare 17 Player : Fedora 39

is this on a Windows Host as well running VirtualBox : Fedora 39 ?

My question would be :

  1. You mentioned the Fedora 39 update, but When did your Host Windows 11 update?
  2. Since you have VirtualBox and VMPlayer installed when were they last updated ?
  3. What hardware are you running ?GPU ?
  4. Is it possible, you had a GPU update from your Host Win11 ?
  5. Are you doing GPU passthrough to to the VM’s ?

Yes, Windows 11 host and two VMs running two different instances of F39 under it. One using VMware and one using VirtualBox.

I don’t think the problem is at the Windows level. See below.

Then I suppose this is only a problem when running F39 in a VM.

I don’t know the extent of what is accelerated under VMware. or VirtualBox. Probably not everything and it probably has to go through a translation layer to map from the Windows host to the Linux guest.

I just looked. Windows was updated two or three days before this happened. Same for my graphics drivers. I don’t think the problem is here. When I reinstalled fedora, I installed from the release F39 ISO. It works fine with accelerated 3D graphics straight from the ISO. When I update all packages, that’s when it breaks. So there’s some interaction between VMware/VirtualBox and the Linux guest that got broken during a recent update.

Yes, VMware and VirtualBox are both running on the same Windows 11 host.

Windows updated about two or three days before this happened. Same for the graphics drivers. I don’t think the problem is at the windows level. When I reinstalled fedora, I installed from the release F39 ISO. It works fine with accelerated 3D straight from the ISO. As soon as I upgrade all packages to the current versions, it breaks. So, it seems like some interaction between F39 and VMware/VirtualBox is causing the problem.

They’re both up to date. That was one of the first things I checked.

Nvidia 2080Ti.

GeForce Experience notifies my when new GPU drivers are available and I usually install them right away. I doubt Windows would ever install new drivers over them.

No passthrough. It’s just whatever VMware or VirtualBox is doing to accelerate 3D. I’m pretty sure it’s not GPU passthrough.

Hello Mark,

Same problem here. It was working perfectly till I made a dnf update before Christmas. I also noticed that disabling 3D accel was fixing it.

Win 10 Host
F39 Guest
Virtualbox 7.12

Hi Steve,

Thanks for posting. You’re the first person I’ve come across anywhere on the net that’s also having this problem.

I just noticed yesterday that if I enable 3D acceleration in VMware Player it gives me the message “You must update tools to enable 3D acceleration in this virtual machine”. I have the latest version of open-vm-tools (12.3.5) so I can’t update it. I wonder if there was a change to linux, perhaps mesa, that broke graphics acceleration and open-vm-tools hasn’t been updated yet to account for this change. I think mesa was one of the packages that got updated when 3D acceleration broke.

I just tried downgrading mesa from 23.3.2-7 to 23.2.1-2 and accelerated 3D works fine in VMPlayer with this version of mesa. I suspect that some change in mesa is out of sync with the part of open-vm-tools that provides accelerated 3D support.

@macosta @mcmanaman Please file this bug to the Mesa team, it looks pretty important IMO. Will help many folks out.

Having the exact same issue.

VMware® Workstation 17 Pro version 17.5.1 build-23298084

Host: Windows 11 Home Version 23H2 OS Build 22631.3374

Guest: Fedora 39

I can also confirm that downgrading mesa to v23.2.x worked!

$ sudo dnf downgrade 'mesa*'