Fedora 39 images crash in UTM virtualization when 3D acceleration is enabled

Problem

Running Fedora 39 images in UTM virtualization (available on Apple MacOS and certain iOS devices) with GPU acceleration enabled will crash the UTM virtual machine with the error
GL_ARB_clear_texture

You can discuss this issue here.

Cause

It is a regression in Mesa 23.2.1 (present on F39 install images) that causes this issue. A patch to correct this issue is already merged in upstream.

Related Issues

Bugzilla report: #2247117
UTM issue report: https://github.com/utmapp/UTM/issues/5749

Workarounds

If you experience this issue, temporarily disable GPU acceleration until there is an updated Mesa with the regression removed. To do this, edit the VM in the UTM app, and under the Devices section, select Display and change emulated display card from “virtio-ramfb-gl (GPU Supported)” to “virtio-ramfb”.

Solution

This is fixed with Mesa 23.3.2 (or maybe even earlier). Fully update your Fedora 39 OS in the virtual machine as usual, reboot, and you should no longer be affected by this bug. If you’ve used the workaround to disable GPU acceleration, revert the steps to re-enable it back again.