GNOME Cannot Be Used After Being Updated on Fedora 39

I recently installed Fedora Workstation 39 on VMWare Workstation. After I finished installation, I ran dnf update to update the whole system and reboot the vm, and then I found that the GNOME Shell was totally unavailable: the mouse was stuck and screen was filled with distortions, and after a few seconds the screen turned to black.

When I leave GUI and turn to CLI mode, the system functioned well. But if I try to restart the gdm, the issue stayed the same. I have tried several ways, such as only updated the GNOME itself rather than the whole system, installed Fedora on VirtualBox rather than VMWare, and I even tried Fedora Silverblue, all these ways cannot solve the problem and GNOME was still unavailable after you updated it.

Host OS: Windows 11 Pro 23H2 22631.3296
Host CPU: AMD Ryzen 7 5800H
Hypervisor: VMware Workstation 17.5.1 and VirtualBox 7.0 (with Hyper-V Enabled)
Guest OS: Fedora Linux 39 (Workstation Edition)
Guest Ach: x86-64

If I am reading the description properly this implies you are using VMWare or VirtualBox on a windows host to install Workstation on the VM.

We cannot assist with problems with VMWare or windows since both are proprietary. You should contact their support for assistance

Try with an usb boot device and test with the live Image to see if the problems persist without this proprietary Os and Software in between. You not have to install it, but at least you get an idea if your Hardware is working with Fedora.

Thanks for your help! I never thought it can be the VM’s problem before since I think both VMware and VirtualBox are very mature hypervisor. I will turn to VM’s community for futher help. By the way, you mean the lastest version of Fedora 39 has no severe problem with GNOME right? That will reassure me because I wanna install Fedora Workstation on physical machine and I need to try out on VM which made me ecounter this issue.

Thanks for your advice! And I need explain that the initial version of Fedora 39 which was just installed from the image Fedora-Workstation-Live-x86_64-39-1.5.iso works well but if I update the GNOME it will crash. That’s so weird, I mean if the hardware has some problem it will immediately crash after I install.

Have you tried logging into Fedora using xorg instead of wayland.I don’t know about vmware but i use virtualbox and my guests will not work using wayland.As far as using Fedora on your machine I along with others here have been using it for years with no issues.

VirtualBox has a few versions of the video emulations, and one of them may work better that the others.