Fedora 39 daily upgrade

i have dual boot fedora 39 and windows 11
and all thing work fine until do “sudo dnf --refresh upgrade” from two days
i can not access the system and it stuck at booting
and i remove fedora and reinstall fresh one and after do the same thing "update system from gnome software center or terminal " fedora stuck during booting

to access the system i must to select the second choice in grub which indicate to previous kernel version (latest kernel update 6.6.4 ) and previous one (kernel 6.5.6)

kindly help me

We’ll need some sort of error message that indicates what the problem is before anyone will be able to provide much help. Unfortunately, the error messages are hidden by default. You’ll have to edit the kernel parameters and remove quiet and rhgb from the list. There are some directions on how to edit the kernel parameters when using the default GRUB bootloader here: Working with the GRUB 2 Boot Loader :: Fedora Docs


thanks for response i removed quiet and rhgb then the system present the following screen

then present the logging screen and after insert my password stuck again at black screen for long time then i force restart and select the second choice (kernel 6.5.6)

in the grub screen to can access and replay for you again

i hope this screen shots demonstrate my issue

You have NVidia graphics I think?
Which model of NVidia card.

Looks like the nouveau driver is crashing in the kernel.

If you had not reinstalled I would have asked you to boot from an older kernel.

You can try adding this to the kernel command line to stop the nouveau driver loading.


I have two black lists for the nouveau but I’m not sure why anymore.
If the above does not work try:

rd.driver.blacklist=nouveau modprobe.blacklist=nouveau

That should allow the system to boot. Then I would suggest that you install the RPMFusion drivers and see if they work with your nvdia card: Howto/NVIDIA - RPM Fusion.

1 Like

It looks like a problem with the nouveau open-source Nvidia driver, which could be the driver code itself or some library required by the driver. I have an old iMac with Nvidia graphics that works fine with the 6.6.4-200.fc39.x86_64 kernel, but others have reported problems with newer Nvidia hardware. You can try the closed source driver from rpm-fusion. Please post the output of inxi -Fvxx (you may need to install inxi) run in a terminal (as text using the </> button) so hardware details can be found by others who have the same issue. If you have not previously used the rpmfusion drivers, there is a HOWTO page.

1 Like

this is inxi -Fvxxoutput

Screenshot from 2023-12-11 00-50-38
this is output of dnf update including rpm

this is the output of neofetch

Screenshot from 2023-12-11 00-49-35
and this the screenshot of about device

$ modprobe.blacklist=nouveau
bash: modprobe.blacklist=nouveau: command not found…

You’ll need to put that on the kernel command line. Use the same method you used to remove quiet and rhgb earlier to edit the command line for a single boot. If it works, follow the instructions in the next section of the GRUB documentation to make the change permanent.

1 Like

Note that it is not necessary to add those options to the kernel command line manually.
And they should not be added unless the nvidia driver is already installed since that may prevent loading any driver for the nvidia gpu and totally prevent booting.

The user installs the nvidia drivers from rpmfusion using sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda and the install process adds those options into the /etc/default/grub file, then as it finishes the install appears to run grub2-mkconfig and adds the options into the kernel command line for the next boot.

Please post text output from a terminal by copy+paste as text rather than screen shots into your messages, using the </> button. This will allow others to find your posts with a search engine.

Your system has Intel UHD (G1) which uses the i915 driver. Maybe blacklisting nouveau will force it to use UHD integrated graphics. If you can get UHD graphics working it will be easier to troubleshoot the Nvidia issue.

Arch linux often has excellent documentation. Arch Linux Nvidia Optimus suggests checking the BIOS for an option to disable the Nvidia graphics, or failing that, powering down the Nvidia card.

The black list line only stops the nouveau driver being loaded and does allow other nvidia drivers to load.
I use this to make debugging rare issues I have seen with the rpmfusion drivers easier.

1 Like

i try this but i can not access again

i think i do some thing wrong during follow instructions in the following link because i use fedora in same device from more than two years and i does not face this problem until try to install nvidia as followed in the following link

every time i try to install nvidia system is crushed

can you look for this link you can find the problem because i can not know what i did
i think i do some thing wrong related to the bios because i remove and format fedora hard disk and the problem still found

i do </> sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda</> this command and restart
appear new message </> NVIDIA Kernel missing Falling back to nouveau</>

but now i can to access to new kernel

output of </>inxi -Fvxx</>

</> CPU: quad core Intel Core i5-1035G1 (-MT MCP-)
speed/min/max: 3027/400/3600 MHz Kernel: 6.6.4-200.fc39.x86_64 x86_64 Up: 6m
Mem: 3.28/11.45 GiB (28.6%) Storage: 1.14 TiB (1.1% used) Procs: 319
Shell: Bash 5.2.21 inxi: 3.3.31

Exactly my point. If the nvidia drivers are not already installed and the user prevents nouveau from loading then no driver can be installed. If that is the only card in the machine then no video will function.

For laptops with dual GPUs it may work but for machines with only an nvidia gpu it likely will not work.

Wouldn’t it fallback to VESA support though?

This sounds like progress.
What is the status of secure boot?
If the command sudo mokutil --sb-state returns Secureboot enabled then secure boot is now preventing the nvidia driver from loading.

There are 2 options.

  1. enter the bios setup menu during boot and disable secure boot


  1. Create your own signing key and enable signing of the nvidia modules locally. This is done as follows:
    a. follow the steps in the file /usr/share/doc/akmods/README.secureboot to create a signing key and enroll it into bios. (those steps must be done using sudo)
    b. remove the current unsigned modules with sudo remove kmod-nvidia-$(uname -r)
    c. create the new signed modules and install them with sudo akmods --force
    d. reboot

No drivers installed? I don’t know since I have never tried. It might.

I do know a similar situation can be managed by using the nomodeset kernel option to obtain basic graphics on newer nvidia GPUs when the nouveau driver does not properly support them. This works for installation and to enable installing the nvidia drivers when nouveau gives a black screen only.

1 Like

Yeah I think that the default behaviour is (used to be) to fall back to VESA support or generic VGA


i do </> enter the bios setup menu during boot and disable secure boot </>

and now i can access and all thing is good

thanks for you

The system uses [Nvidia Optimus]. The integrated UHD GPU should be supported by the Intel i915 driver, so unless the iGPU has been disabled in BIOS, blacklisting nouveau should still use the iGPU. The neofetch output has changed from UHD+Nvidia to 2xUHD so the iGPU appears to be working.

Maybe the restart was done before akmod-nvidia was finished. If so, you are not the first to be caught out by this.