Quick PSA for Nvidia users upgrading from 38 to 39 with solution

Greetings Fedora Community,

I encountered an error on upgrading to Fedora 39, but also found a simple fix. Now while I can’t speak for those that upgrade via Gnome Software from 38>39 as that’s not the upgrade path I picked, though I assume the same may apply. For users like myself that upgraded via dnf from this guide:

you will run into a problem after reboot. This ONLY applies to Nvidia users, so if you don’t use Nvidia you can safely ignore this. Also, it’s safe to upgrade to 39, just know you may come across this issue if you’re an Nvidia user.

Once upgraded to 39, a reboot will show the error:

NVIDIA kernel module missing. Falling back to nouveau

which means your Nvidia drivers will not load or be used when you log in.

The reason for this appears to be a bit of a long standing bug as reported here:

So what’s the solution?

In your terminal run:

sudo depmod -a

Once the command finishes, do a reboot and the error should be gone and you should be able to use your nvidia drivers once again without issue while enjoying the latest and greatest Gnome that Fedora has to offer.

Hope this is helpful to anyone and all credit goes to user kwizart on libera.chat in # RPMFusion for helping me troubleshoot this issue. Thanks mate!


If you’re a complete noob like me you’ll need a little more info:
Scenario, dual boot with win11, secure boot enabled.
Restart machine and when you get to the GRUB boot screen press “e” when on the “Fedora 39” line (use arrow keys to move up and down)
On the line that starts with “Linux” scroll all the way to the end of that line (note that the line has word wrap enabled)
Add “nomodeset plymouth.enable=0”


You’ll probably see an error, use “ctrl + alt F2” to get to the terminal
login with your account
Now do the step listed above “sudo depmod -a”

and reboot!

I’ve created a proposed Common Issue for this here:

1 Like

I did following, which worked, before coming to this post:

  1. Select older kernel from boot menu.
  2. Run following commands:
sudo dnf remove \*nvidia\*
sudo dnf install akmod-nvidia
  1. Restart and select the latest kernel.

This does one thing unintended. There is a required package (nvidia-gpu-firmware) that is provided by fedora and gets removed when that command is run.
It should be changed to sudo dnf remove \*nvidia\* --exclude nvidia-gpu-firmware

When the command is run as you show and you have nvidia gpu hardware then it must be followed with sudo dnf install nvidia-gpu-firmware to restore that firmware package. Without the firmware the GPU will not work properly.

The common issue linked above shows ways to perform the repair without resorting to a full reinstall.