NVIDIA kernel module missing. Falling back to nouveau [FEDORA 40, Gnome]

Good evening friends, Today I upgraded to Fedora 40 from the terminal, the installation was successful, the problem came when I rebooted the system. Before logging in, I got the message “NVIDIA kernel module missing. Falling back to nouveau”. It won’t let me log in using Xorg, it only lets me log in using Wayland.

I’m using a RTX 2080 with the proprietary drivers installed with sudo dnf install akmod-nvidia

What should I do to fix this problem?

Thanks for your help.

Is secure boot enabled? mokutil --sb-state will answer that.

If secure boot is enabled then the nvidia modules cannot be loaded unless you

  1. disable secure boot in the bios setup menu
    or
  2. sign the modules so they can be loaded with secure boot enabled.

It is late enough that I cannot remain to walk you thru this, but signing the modules is relatively simple

  1. follow the steps in the file /usr/share/doc/akmods/README.secureboot to generate the key and enroll it in bios. (the commands require the use of sudo)
  2. remove the unsigned modules with sudo dnf remove kmod-nvidia-$(uname -r)
  3. rebuild the modules with sudo akmods --force
  4. reboot

Hi @computersavvy, can I do that by booting from a previous kernel version? Because I have the problem with the latest version. Thanks.

PS: I have Secure Boot enabled in the BIOS, but my ASUS motherboard does not allow me to disable it.

Finally I took the “easy” way, uninstall and reinstall the Nvidia drivers and it is already solved.

Thanks.

1 Like

Added f40

I am facing the same issue. Tried making secure boot, facing this error

mokutil --sb-state
EFI variables are not supported on this system

Any idea how to fix this

Hi, I avoided doing the Secure Boot thing by reinstalling the proprietary Nvidia drivers and the problem was fixed.

1 Like

That says you have installed fedora in legacy boot mode so secure boot is not possible.
Try a reinstall of the drivers as noted by @cesaraquino