Nvidia drivers - falling back to nouveau after upgrading to Fedora 38

Hi, I just upgraded to Fedora 38 and my nvidia drivers are now unfortunatelly disfunct. Have no idea, what could have caused this. I use the nvidia-470xx drivers and they worked fine with Fedora 37. Has anyone a idea, how I might be able to solve this issue? I would be greatful for any help.

Not sure what this means. Which Nvidia drivers were you using before the upgrade? Is the updated system failing to reach the GUI environment? Have you tried (re)installing rpmfusion drivers? It would be helpful to mention your hardware details.

I had a few issues with Nvidia drivers and updates. What I do to fix is remove them and re-install them.

sudo dnf update # To verify all packages are fully updated.
sudo dnf reinstall kernel\* # To make certain all kernel packages are in sync.
sudo dnf reinstall akmod-nvidia # To rebuild all the nvidia modules.
sudo reboot

If that does not work, I remove then reboot. In a console, I install the driver, and reboot. Then, it generally works.

It is a pain and I wish I did not have to do this… ¯\_(ツ)_/¯


dnf reinstall kernel-core
did it for me. It triggers a rebuild of the nvidia modules.

1 Like

Sorry - am not sure, what drivers I was using before.
The updated system boots just fine - only nvidia is not working.
Not tried to re-install anything

If I do type this - it says akmod-nvidia is present but not installed.
Do I have to use akmod-nvidia-470xx.x86_64 which seems to be the relevant driver for me and which also popps up, when I write the command: dnf list installed nvidia
Unfortunately do not know, how to use a console to install the driver - could not try this…

Using linux command line tools (console or a terminal) gives access to many things that can’t be accomplished with the GUI tools, either because the GUI is broken or due to limitations of the GUI tools. I recommend Linux Command, partly because there are translations.

Thanks - I know the linux command line, but am not really used to work with it in a more in depth style.
How can I know, if I can fix my driver problem on my own? A few months ago, I had similar issues with Fedora 37 and I had to wait, till they updated the Kernel, in order to make the thing work again…

This actually worked! Thanks a lot!

Any console, whether terminal or an actual console, will work. I tend to switch to a normal console as Nouveau gives me utter rubbish on a 4k display.

If it is not present, you need to install akmod-nvidia and things should work. Hopefully…

Note that the OP is using the 470xx drivers as stated in post #1 and would need to remain on that with the hardware he has. Installing the newer drivers would likely cause many more problems.

I have noticed that several indicate problems with the 470 drivers and the 6.2.x kernels, so users must be careful in how they upgrade to avoid breaking the system with the older nvidia hardware.

I had somewhat similar issue, and after reinstalling the kernel-core when nvidia drivers were used again it became pretty unstable: gdm login screen was not displaying properly (just a blurred background and no mouse response)

I had to switch to the nouveau driver to be able to use the computer, (Its a desktop with GTX 1060 graphics card)

What finally got the random freezes fixed was adding nvidia-drm.modeset=1 to the kernel cmdline, i did that using sudo grubby --update-kernel=/boot/path-to-your-kernel --args=nvidia-drm.modeset=1

(sharing here in case its useful to someone else)

have been using it whole day without any freezes till now :crossed_fingers:

Please mention the Nvidia hardware you have and the driver version that failed for you.

Thank you very much