Really Long Boot Time

So I am booting off of an SSD with read speeds above 1Gb/s with a Core i7 9750h and it still takes me close to 2 minutes to go from pressing the power button to logging in. Can anyone help me diagnose this issue?


Same problem on Lenovo Ideapad 320. No matter what distro I’m using, takes too long till it loads. No problem with Windows though.

Here are some useful commands to learn more about the processes “that eat up time” when booting up:

1.) systemd-analyze

2.) systemd-analyze blame

3.) systemd-analyze critical-chain

Let’s see what the output is and then we can diagnose…

PS: Here is another nice one:

systemd-analyze plot >> test.html && firefox ./test.html

PPS: Or here, even nicer: systemd-analyze plot > boot.svg

1 Like

When I run: systemd-analyze

My output is:

Startup finished in 7.306s (firmware) + 2.130s (loader) + 1.556s (kernel) + 1.980s (initrd) + 1min 41.144s (userspace) = 1min 54.118s reached after 1min 40.056s in userspace

Is that at all helpful?

Run “systemd-analyze blame | head” to see which processes are being slow.

1 Like

That command outputs the following:

1min 33.489s systemd-udev-settle.service
7.455s plymouth-quit-wait.service
6.135s NetworkManager-wait-online.service
1.088s dracut-initqueue.service
705ms initrd-switch-root.service
603ms firewalld.service
577ms lvm2-monitor.service
518ms systemd-logind.service
425ms akmods.service
425ms udisks2.service

On a different note, while booting up, I pressed escape to see what was going on, and I saw this.

1 Like

I had the same problem when I first started with Fedora, it’s caused by a usually unnecessary service. Although it may be needed if you have complex storage setups like a RAID.

In my research, the best way to solve it is just by masking the service, using sudo systemctl mask systemd-udev-settle in the terminal and rebooting. Here is a related thread, if you’re curious.

That solved the problem! Thank you so much!

Out of curiosity, since RAID is something I frequently do with my Windows machine, would I need to wait the three minutes every time if I was using a RAID setup?


I’m not totally sure, to be honest, I don’t have much experience with fancier setups :grinning:

Hopefully someone in here knows what’s up with that.

I am now receiving a message when I log in. This is the second time I have received this message. It doesn’t appear to be a major problem, but I would like to understand what the system is telling me. I have included a screenshot of what I am looking at.


This is after clicking the details button.

Is this related to the boot-up issue in some way?

Thanks in advance.

I also got this problem. Following this thread to solve my problem of long boot time.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.