Printing issue with samsung ML-1640

Hi everyone, I have a problem with Fedora 35 and my laser B/N printer Samsung ML-1640.
The printer is recognized correctly by Fedora, but when I print something the printer heats up, the green led on the printer blinks (like normal) but does’t print anything…
The same printer works fine under Windows 10 or Pop_OS 20.04 LTS, so the issue is on Fedora 35 (tested on different PCs)

I also tried printing a test page using CUPS web interface (http://localhost:631/), but still nothing is printed, same behavior as before.
Also, I am not notified of any printing errors. I also checked the logs…
How can I fix this issue?


Is this a network printer or locally attached?

If it is a network printer, does it require any firewall ports to be open?

I forgot to specify, it is a local printer connected via USB.

Have you tested drivers like:
Samsung ML-1640 Laser Printer series Software and Driver Downloads | HP® Customer Support

Hi, I installed the drivers, but the printer still doesn’t work…
It’s a cups bug 1935318 – old samsung USB devices malfunction with the current (250ms) timeout for usb bulk transaction

1 Like

I fixed the issue by installing the splix package and selecting the correct driver in GNOME settings.


Description : This driver is usable by all printer devices which understand the QPDL
(Quick Page Description Language) also known as SPL2 (Samsung Printer Language)
language. It covers several Samsung, Xerox and Dell printers.
Splix doesn’t support old SPL(1) printers.