Paper going through printer twice


I have been using another Linux distro for years with this same equipment (64-bit Intel, HP Laser printer) without any printing issues. I recently switched to Fedora 35. If I print a file with 3 lines on it via lpr, it prints fine. However, the single page is going through the printer twice as if it were doing dual sided printing. I have checked every place I can thing of and it is set to single-sided printing. I even tried:

ls -ld t* |lpr -o sides=one-sided

It still runs the paper through twice even though I am printing 3 lines on one side.

Again, I never had this problem with the other Linux distros.

Sure appreciate any help.


You are using an HP printer.

  1. Is it wifi or USB connected.
  2. did you set up the printer with hplip or allow the system to automatically configure it?

Apparently it did set up to print, but if you did not use hplip to configure it then the driver may not be the proper one.

The hplip package is installed automatically when you do a new install of fedora 35, but there is another package “hplip-gui” that gives you a gui interface to configure and manage the hp printer. That is also in the fedora repo so it is easy to install.

I have always needed, for my HP printer, to manually remove the automatically configured printer that is set up by avahi then use the HPLIP Graphical Tools icon that is installed with the hplip-gui package to configure the HP printer. It sets everything up properly for me. Note that if your printer is an AIO (or as HP names it a MFP) then you will need to install the plugin to use the scanner.

Once installed and printing properly the system print dialog can switch between single and double sided printing. The gui also allows you to set the default print mode as single or double sided.

You might also be able to set the default print mode from the printer local control panel, though since you do not say which model I cannot check that for you.

A third mode of configuring the printer is the cups interface at http://localhost:631 with your browser

  1. It is not wifi or USB. Just network - Ethernet.

  2. I set up the printer via System / Administration / Print Settings
    I then clicked “Add” to add a printer.
    It found my printer under “Network Printer”
    I added it accepting all of the defaults.

It is an HP Color Laserjet CP2025dn printer.

Device URI is dnssd://HP%20Color%20LaserJet%20CP2025n%20(90B14D)._pdl-datastream._tcp.local/

I do not see a driver setting.

I installed package hplip-gui through dnf but still have no program names “hplip-gui”

After installing hplip-gui, there is no menu option for it either. (I am using the MATE desktop.)

I changed the URI to: hp:/net/HP_Color_Laserjet_CP2025dn?ip=

I got that from another computer. Now it works.

Thanks for the help!!

Glad you got it working. :+1:

The main hplip setup tool from the command line is hp-setup and does the same as the gui for configuring the printer and installing the scanner plugin.
The scanner plugin can also be installed with the hp-plugin command.

If everything is working well on the printer for you then that is good and I wish you a long time enjoying that printer.

Yes, everything is working well. Thank you, Jeff.