HP printer stopped printing

my HP printer stopped printing,
while it used to work

error message

We need a lot more info.
Printer model?
Connected via wifi, usb, ethernet?
If the printer is network connected is the IP address fixed or dhcp assigned?
If assigned by dhcp is the address reserved so the printer always has the same IP?
Fedora version?
hplip version?
when was fedora last updated?
Have you changed network config or power cycled the printer?
What does http://localhost:631 on your browser tell you about that printer?

Fedora 38 Gnome
system updated yesterday
printer Connected via usb
I have NOT changed network config
http://localhost:631/printers/ :
HP LaserJet m14-m17, hpcups 3.22.10 Idle

I installed the printer with the
sudo hp-setup command a few months ago
the printer has been working flawlessly until today

Thank you for the additional information.

I sometimes have problems with an hp printer config and the fix I use that has always worked has been to use the gnome settings panel and totally remove the printer config.

I then reconfigure it with hplip (hp-setup works from the cli though I use the gui from hplip-gui) and it is back to full function.

There was a time when the ipp-usb package was introduced where it totally blocked use of the proprietary driver for usb connected printers. It may be a factor here but I have no usb connected printers to test with. One may also remove the ipp-usb package with no negative affects when using hplip and HP printers.

Screenshot from 2023-08-11 00-19-58

So, if i undrestood your suggestion well:

  1. remove these two (which are actually ONE AND THE SAME printer)
  2. reinstall the printer using the
    sudo hp-setup
    command on the terminal

That is what I would do.
The first seems the one configured by hplip. The second seems the one configured by default by the system.

For me with these definitions seen
image

I only EVER use the first since the first is the one I specifically named and defined with hplip while the second is automatically configured by the system and never works. I think avahi automatically configures that but it does not have the proper config to print.

If your HP printer is an MFP then only when using the printer definition done with hplip, and only when hp-plugin is run to install the hp plugin to support the scanner is one able to use the scanner on the printer. Hp-plugin is automatically run by hp-setup during the initial setup, but when the system does an update of hplip one must rerun hp-plugin to keep the versions matching in order for the scanner to function.

I removef the printer and reinstalled it three times,
but it didn’t work,
when I turn on the printer
its characteristic mechanical click clic clic is NOT heard

sudo hp-setup

HP Linux Imaging and Printing System (ver. 3.23.5)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
Searching… (bus=usb, search=(None), desc=0)

Done.

hp-setup -b usb

HP Linux Imaging and Printing System (ver. 3.23.5)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QSocketNotifier: Can only be used with threads started with QThread
qt.qpa.qgnomeplatform.theme: The desktop style for QtQuick Controls 2 applications is not available on the system (qqc2-desktop-style). The application may look broken.
Searching… (bus=usb, search=(None), desc=0)

Done.

This is now working?

If it still is not working then one may try the suggested removal of the ipp-usb package.

I even deleted hplip and reinstalled it.
The printer is still IDLE.

I don’t know how to remove the ipp-usb package.
Please, tell me how because
I’ve read in the fedora discussion
that the removal of the ipp-usb package
solved a simalar problem in the past.

sudo dnf remove ipp-usb would remove that package.

Is there a specific reason you did not set up the printer for network connect? If it were then the usb issue would be moot.
The user manual tells how to configure it for wifi connection.

sudo dnf remove ipp-usb

The ipp-usb package is only needed of you want to use ipp-everywhere (aka driverless) with a printer connected via usb. In other cases it may block access to the usb connected printer.

my printer is NOT a wireless model

I removed the ipp-usb package,
but the printer does not print,

when I press print
after 1-2 seconds a message appears:
printing stopped…

Have you installed the hplip-gui package?
If so one can manage the print queues from there.

One can also do test prints from there.

Did you reboot after removing the ipp-usb package? If not then please do so.

I have installed the hplip-gui.
i rebbooted the system.
but printer stops printing

maybe the problem is here:
Screenshot from 2023-08-11 23-12-30
when I try to install it…
Screenshot from 2023-08-11 23-13-26

Screenshot from 2023-08-11 23-21-38

With that I would strongly consider doing sudo dnf remove hplip and allow it to remove all dependencies, then after a reboot doing sudo dnf install hplip hplip-gui.

Following that one should be able to once again set up the printer.

The message about python3 may only be a timeout on the action and not actually a problem – or it may be a problem. The uninstall and reinstall is an attempt to verify that. Hplip does use several python modules.

The last item about the file checksum – is that after the attempt to download and install the plugin or when exactly does it appear?

I executed
sudo dnf remove hplip
allowed it to remove all dependencies,
then after a reboot
sudo dnf install hplip hplip-gui

now the printer does not even start the printing procedure…

What are you using to get that screen for printing.?
It is not one that appears from hplip gui, nor is it one that appears when printing from my browser or any other app I have installed.

I cannot do a test that would be comparable unless I could have the same software installed.
From the cups inteface I see this for my printer. What does yours look like?

Jeff, first of all, thanks for your help and patience.

  1. "the backend does not exist " message appears
    when I try to print a pdf file
    (I suppose it’s the software that opens pdf files in fedora 38 gnome )

  2. but as I already told you
    (look at the screenshots above)
    the driver plugin is STILL required
    but I cannot install it
    because python 3 is not responding…