Problem with adding HP LaserJet printer

I am running Silverblue 35. I think that I added my printer correctly in the Settings. I found what looks like the correct driver for it in the database. However, I cant print from any application. The printer is always “rejecting jobs.” Any ideas on how to get the printer to work correctly?

If you were running workstation the fix would be easy. I have no experience with silverblue.

How would you fix it on the Workstation version?

Since hplip is installed by default, I would install the hplip-gui, make certain there are no configured printers (for this particular one, deleting any configs already in place to avoid conflicts), then use the ‘HPLIP graphical tools’ tool to configure the printer and to manage it after it was installed. If I planned to use the scanner I also would ensure the plugin was installed and that Sane and libsane-hpaio were installed.

In a nutshell that is all that is required for me to install and use an HPLaserjet Color multifunction printer on Fedora Workstation.

Is this a network printer?

If so, is your firewall enabled? Did you open all the ports required to make an HP Printer work?

Yes it is a network printer. Its on my wireless network. I don’t know if the firewall is enabled and I don’t know which ports are open.

I don’t have hplip installed and I don’t see it in Software.

What is the output of

firewall-cmd --state  


So your firewall is enabled. I would temporarily disable and see if you print after that. If you can, then you can re-enable it and try to open the correct ports.

You should be able to stop it with

sudo systemctl stop firewalld

If your printer still doesn’t work then the firewall isn’t your problem and you should restart it with:

sudo systemctl start firewalld

I stopped the firewall and tried to print an email from Geary. A little window popped up and said “Printing Complete” but there was no output from the printer. The document did not print. So I’ve re-started the firewall.

Since the communication with the printer over the network is originated from the PC I have never had to open any firewall ports to make it work.

I really suspect the issue is something unique to the silverblue config and hope that someone using silverblue with an HP printer would jump in here and assist. My only experience is with Server and Workstation so I don’t know the silverblue nuances.

It is possible you may need to install a flatpak of hplip and hplip-gui. As I stated above hplip is in the default install of Workstation and hplip-gui is in the repo for easy install.

I have. For my HP printer I had to open tcp 631 and udp 3702.

I don’t think that there are flatpaks of those packages.

That is strange. This is what is open on my daily driver with a wifi connected HP Laserjet & I can print and scan to my hearts content.

# nmap eagle
Starting Nmap 7.80 ( ) at 2021-12-11 11:14 CST
Nmap scan report for eagle (
Host is up (0.0000060s latency).
rDNS record for eagle
Not shown: 997 closed ports
22/tcp   open  ssh
80/tcp   open  http
3551/tcp open  apcupsd

Nmap done: 1 IP address (1 host up) scanned in 0.12 seconds

On the printer I see this

# nmap
Starting Nmap 7.80 ( ) at 2021-12-11 11:18 CST
Nmap scan report for HP (
Host is up (0.0030s latency).
Not shown: 993 closed ports
80/tcp   open  http
443/tcp  open  https
515/tcp  open  printer
631/tcp  open  ipp
8080/tcp open  http-proxy
8291/tcp open  unknown
9100/tcp open  jetdirect
MAC Address: xx:xx:xx:xx:xx:xx

Nmap done: 1 IP address (1 host up) scanned in 7.87 seconds

Perhaps we have different printers. I can tell you this though, if I close those ports, I can’t print. When I open them, I can.

You should be able to install packages, more info here → Getting Started :: Fedora Docs using rpm-ostree install or if it is not available use a toolbox.

You may want to try adding the printer using ip address from the system dialog if you’re using the network.

1 Like

one answer could be:

  • install selinux troubleshoot
  • see if selinux blocks printing

For my HP printer I had to open tcp 631 and udp 3702.

How would I do that?

You only should do that if the firewall is determined to be the issue. If not, don’t worry about it.

My printer was trying to print the wrong paper format. It could be that small an issue.

Good Morning!
Try by your printer’s IP address. Just type it into a browser tab.

1 Like