Laptop can't enter sleep mode after Kernel Update

A few days ago I updated my fedora installation as always and, among other things, the Kernel updated itself from version 6.2.14-300 to 6.3.4-201.
The problem is that, after I rebooted my system, I found out that sleep mode was not working anymore, with the laptop waking up after few seconds every time after I’ve pressed the Suspend button. I’ve also felt like the laptop was turning hotter, but I’m not sure if this was just a feeling, or it was a real consequence of the update.
Has someone else encountered the same issue? Any idea on how to fix it?

I have a related problem where the laptop doesn’t wake up, and it’s also related to an update from kernel 6.2.x to 6.3.x, so I’m thinking there could be some sort of suspend/resume regression in kernel 6.3. I created a separate post for my problem.

In your case it’s probably easier to debug, because your laptop wakes up, so you have access to all the logs.

It would be helpful to provide some more information, like the laptop vendor/model. On a different note, if you look at the kernel log, do you see anything unusual right before the suspend?

1 Like

Thanks for your tips!
I’ve tried to check the logs (after having updated in the meantime to 6.3.8) with journalctl -f and the first thing I noticed (see first screenshot attached) is that few line after Operation 'sleep' finished there was a starting nvidia-resume.service that seemed to be the cause of my issue.
So to check if my hypothesis was correct I tried uninstalling all the nvidia drivers and booting my laptop with nouveau that’s shipped with Fedora, but nothing has changed.
So I checked again the logs and what I found (see second screenshot attached) was a line saying PM: suspend devices took 0.535 seconds (that I guess is the last line regarding entering sleep mode, but idk) and immediately after these 3 lines:

ACPI: EC: interrupt blocked
ACPI: EC: interrupt unblocked
PM: resume devices took 0.301 seconds

So the problem apparently was not the nvidia drivers… any idea on what it could be?

The above screenshots appear to show the network resuming from sleep first. I wonder if Wake-on-LAN packets could be causing your system to resume?

1 Like

I thought about that too, but I tried disabling it and the issue persisted…
As I’ve written in this other topic the issue seems to be with the PCIE controllers, that I disabled in /proc/acpi/wakeup as a temporary fix.

I hope that in future kernel updates this will be fixed properly so that disabling those lines manually won’t be necessary anymore