Immediate wake from suspend; used to work. Want to learn how to narrow it down

I’m a newer Fedora user and still learning about the best ways to troubleshoot.

I’m running Fedora 40 Workstation, and my Asus G14 laptop used to sleep/suspend as expected. Sometime recently, this stopped working.

As for what I’ve done, I’ve made sure these were enabled:

sudo systemctl enable nvidia-hibernate.service nvidia-suspend.service nvidia-resume.service nvidia-powerd.service

I’ve also tried to use journalctl -b to see if I can notice what might be keeping my system from suspending properly. Scrolling to the end, I’m not seeing anything obvious and I don’t know how to narrow it to just power related events.

Airplane mode on doesn’t fix it. I’ve turned Fast Boot off, and Quick Startup (Hiberntion) in Windows 11 is off, even though it runs off an external drive anyway. I’ve also disable Anime Matrix completely, with no change.

Tried current and last kernel 6.8.9-300 and 6.8.8-300, no change between them.

Any thoughts of what else to try, or tips? I’ve done some searching in Common Issues and it seems it’s related to coming out of suspend for most people.

Thanks