Keyboard keys changed after latest fedora 35 update

Hi Guys,

I am using Fedora 35 on my Apple Macbook Air 2017, and today something very annoying happened to me. In the morning (Budapest Time), I updated my laptop (sudo dnf update -y), and I have received a massive update (around 6000 items to be updated), and after the update, everything seemed to work fine, except one strange thing:

  • My keyboard layout changed to work as expected. My 0 (zero) and í keys changed. So when I press 0, it types í, and when I type í, it types 0. My keyboard is hungarian, and my keyboard settings, I have the same Hungarian layout, and if I open keyboard layot, it shows me the correct layot, but if I press the í or 0 keys, in the keyboard preview it shows me like pressing really the í or 0 keys (so the displayed layot correct, the displayed pressed keys correct, except I pressed 0 instead of í and vica versa.

I tried language and region, my language is English (United States), and my formats is Hungary.

I tried to remove my keyboard from input sources and added it again, but the same happens.

In my macbook a few month ago the keyboard was replaced by a repair store, but they told me the replaced keyboard is an official apple product. Till the today update, the keyboard worked fine.

Could you help me what could be the issue?

Thank you in advance.
Best wishes,
Peter Mezei.

If I type xev in terminal, and try to test the two keys I got these:
when pressing 0 button:

KeyPress event, serial 34, synthetic NO, window 0x2600001,
root 0x2af, subw 0x0, time 2924240, (520,637), root:(558,744),
state 0x0, keycode 94 (keysym 0xed, iacute), same_screen YES,
XLookupString gives 2 bytes: (c3 ad) “í”
XmbLookupString gives 2 bytes: (c3 ad) “í”
XFilterEvent returns: False

When pressing í key:

KeyPress event, serial 34, synthetic NO, window 0x2600001,
root 0x2af, subw 0x0, time 2969722, (556,219), root:(594,326),
state 0x0, keycode 49 (keysym 0x30, 0), same_screen YES,
XLookupString gives 1 bytes: (30) “0”
XmbLookupString gives 1 bytes: (30) “0”
XFilterEvent returns: False

So it looks like the two keys behaves like they would physically changed. But no.

Welcome to ask.:fedora:edora @mezeipetister

It looks like the big update was from 5.15.x to 5.16.x ? On such major updates it happens that some bugs come up. Please test to startup with an older kernel, not 5.16 to boot and see if everything is as it should be. If yes you have to check if there are variants in the Hungarian keyboard layouts. Might be that there it changed something.

If not, we see if it makes sens to make a bug request, to let the developers to know that something changed.

Ok, I will try to downgrade my kernel. Currently I plugged a USB keyboard, and that works fine. Only my macbook keyboard behaves strangely. Does this means something to you?

press the right shift or ESC while booting and you should get a boot menu where you can select older kernel.

As I mentioned new kernel equal new problems.

Ok, so with 5.15.x kernel my keyboard works fine. Hungarian keyboard in settings seems to be the same. But now works nicely.

What is your desktop environment ? Gnome ?

Yes, Gnome 41.3; Wayland

In the meantime I posted a bug report to the kernel dev team, and they replied very quickly with a possible reason and solution:

It works perfectly.

1 Like