Fedora 36 KDE: Korean input

I have installed Fedora 36 KDE (X11).
If I try to add the Korean keyboard layout using the “System Settings”, even if the icon in the bottom right is “KR” it is still writing “English” characters.

Any ideas?


you did install Korean fonts.
did you ever use ibus-typing-booster ibus-typing-booster
also see How to use ibus for inputting Chinese in Cinnamon on Fedora - SysTutorials

Korean characters are rendered correctly so I am assuming that korean fonts are installed.
Interestingly I have just noticed that if I click on bottom right icon to change the keyboard layout and select the other one the (for example US instead of KR) the indicator does not change.

Also if I do a preview of the layout the character on the “preview” keyboard are still english.

Am I missing something obious?

I managed to solve by:

  • sudo dnf install -y fcitx5-hangul kcm-fcitx5
  • im-chooser: select “Use fcitx5” and logout
  • “System Settings” → “Regional Settings” → “Input Method” → “Add Input Method” → “Hangul”
  • “Ctrl+Space” changes layout
1 Like