Fedora 35 types backslash '/' when I hit Control Right button


Has anyone seen this problem? I’m using an English layout keyboard (international with dead keys, but even changing the layout to a different English version does not help) and whenever I hit right control button a slash appears on any editor I’m using.

The curious is that when viewing the keyboard layout (select “View Keyboard Layout” in the Keyboard settings) , and hitting the right control key, I see the right control key showing up as pressed in the view. But this is the only moment the key is recognized as a CTRL key that I noticed when using my Fedora.

If someone has any idea of how to troubleshoot this, I’d appreciate it :slight_smile:


1 Like

Hi @flaviarnn , welcome to the community! Please take a look at the introductory posts in the #start-here category if you’ve not had a chance to do so yet.

I haven’t noticed this issue yet, no. I guess the first thing to do would be to create a new user and see if the issue persists. If it does, it’s a system issue, otherwise some configuration in your user that’s causing it.

Hi @ankursinha , thanks for responding!

I think that this issue may be more common than it looks like, but most people are unlikely to use Right CTRL. Being left handed, though, I need to use that key, with my right hand, while using the mouse to browse code in my IntelliJ Idea (the ctrl key allows you to enter declarations of methods, classes, etc).
Right now I’m using my right hand to press the left ctrl key, while moving the mouse with the left hand, and this is not comfortable :frowning:

Okay, I did as you suggested, I created another user, and the right ctrl key also does not work as a ctrl key. It outputs slash ‘/’ when I type with it on any editor or the terminal.

This appears to be some sort of bug to me. My Fedora 35 is freshly installed, with no special tuning or whatsoever.

1 Like

I’ve tried two different keyboards and I’m not seeing this behavior. For what it’s worth, I’m using an en_US keyboard layout. If you can provide the physical keyboard layout and language you’ve set in Fedora, that could be useful for debugging. When you say, “English layout”, do you mean UK English? You mentioned dead keys - Is the other Ctrl possibly getting mapped to another key?

1 Like

Do you have some input method installed? That may be the problem. I have experienced with misconfigured fcitx spitting out S for Ctrl buttons before.

1 Like

Hi. Maybe it’s not a software problem. Do You have access to some other keyboard You can plug in that computer? (Btw. there are lot of English intl. subvariants: US, intl., with dead keys; UK,i.,wdk; Workman,i.,wdk,Dvorak,i.,wdk)

1 Like

Hi everyone,

The Fedora is installed on a laptop with a ABNT2, the specific type of the keyboard is “Portuguese (Brazil, IBM/Lenovo Thinkpad”.

During my Fedora installation setup, I selected language “English”. When selecting the keyboard model, I added the above Brazilian type, but I also added an “English (US, intl., with dead keys)”, because I knew I was going to use the fedora with a wireless keyboard.

My keyboard model is MX Keys Logi, btw. I tried with other keyboards and the problem persists.

I recently discovered that a co-worker, who also installed the very same Fedora at a machine identical to mine, doesn’t have the same problem, @vwbusguy . The difference is that he installed the Fedora with only the Brazilian keyboard. When he decided to use his external keyboard, after Fedora was already installed and updated with the latest upgrades, he added an English US international layout. So, maybe that’s the cause of all of this, and it would explain as well why you couldn’t reproduce it.

So, after hearing my co-worker’s story, I decided to check the laptop keyboard right control key, using obviously the correct layout, the Brazilian one. To my dismay, I discovered that the right control key also types a ‘/’ instead of working as a control key. So, it appears that somehow the bug is in the Brazilian keyboard, and somehow it is affecting the other layout (would that even be possible?). I’m not sure why, or how to fix it.

Regarding input methods, I only have the two keyboards config I just talked about. And this is necessary because the built-in keyboard in the laptop is different from my external keyboard. Btw, I use Quick Lang Switch gnome extension to switch between them, not sure if this affects anything. If you also have multiple keyboards, @lilywhite, maybe the problem you mention is similar to mine?

As for the English variants, I was referring to the ones compatible with my US international keyboard, so there are other types, such as the non-international, without dead keys, etc, that also are compatible with my keyboard.

1 Like

Thank you everyone for helping me with this problem!

After typing my previous message, I decided to mess with my keyboard configuration in Gnome. I went ahead and removed the Brazilian layout, leaving only the English one and… tadah! Right CTRL key started working as a CTRL key :smiley:

After that, I added the Brazilian keyboard back, and both continued with the Right Ctrl key working. I rebooted and it still works, for both layouts. I’m not sure what happened, but it might save someone else’s time, that it is worth a shot adding and removing back the layouts.

Notice that, before, I had rebooted the laptop several times and the bug persisted. So, the credit goes all to removing and adding back the Brazilian keyboard layout.

Last but not least, this is totally unrelated to the Quick Lang Switch Gnome extension, it appears that enabling and disabling it made no difference in my problem.

1 Like

That’s very odd indeed, especially given that the bug persisted when you created a new user? :thinking:

Yes @ankursinha , very odd indeed.

I created the new user, rebooted, logged in, logged off, everything, and the bug persisted all the time.