Keyboard layout incorect since gnome upgrade, no change possible

I am having an issue due to fedora or gnome applying the default keyboard layout for EN (qwerty) since upgrading to gnome 4.1. I use a FR keyboard (azerty) and locale settings but have the language put to EN-GB, my PC runs Nvidia (legacy 470.103) on X11 and not on wayland. The localctl comand reflects this. Gnome settings always shows empty keyboard layouts and updating the information doe not apply any changes. Adding the keyboards did not enable keyboard switching. Does anyone have either a solution or workaround? I tried changing the language to FR (which I dont like to use here) but it also asked to rename lots of directories I do not want to, so that was a non starter for me. Thanks. Patrick.

Did you check this out?

System Locale and Keyboard Configuration :: Fedora Docs

Hi, I had not checked this out. However my locale is set correctly and does not work.

localectl status
System Locale: LANG=en_GB.UTF-8
VC Keymap: fr-azerty
X11 Layout: fr
X11 Variant: azerty

Those do not match.

Hi computersavvy,
It so happens that I want to read my linux in English and not in French, hence the Lang=en_GB.UTF-8 bit on line 1 of the locale status command. However, i have french hardware (pc) with a french keyboard. These are what the keymap, layout and variant are about. They never cause problems in the last 10 years so it is not a new configuration issue.
What is new is that it does not work anymore since the upgrade to gnome 4.1and kernel 5.17.5 (no change either when downgraded to 5.17.4).

On another note, when logging in initially to the session the keyboard is fine, and once in the session (gnome 41.6 in this case), the keyboard has swapped to en_GB (qwerty) and cannot be changed.

Best regards,

Hi again,
Just upgraded to Fedora 36. No luck either. Same situation.
F36, Nvidia, Gnome 42, X11.
Best regards,

Did you give a try to:

localectl --help

Set it to US and when it works back to GB to see if this helps.
I had a similar problem with German and English.

I solved the problem with the app:

Please read also the man page of it.

Hi ilikelinux, Thanks for the tip but it does not work for me. My linux (now newly Fedora 36 with gnome 42) is fine in English. What does work to revert my keyboard is the command line:

“setxkbdmap -model pc105 -layout fr -variant azerty”, however this is not boot persistent.

There seem to be a number of bugs identified around ibus and gnome with symptoms looking like mine. For me it is most (if not everything) manageable in the Gnome settings that’s off. This looks like ibus as it is used for most things there it would seem.
Thanks, Patrick.

Try to put it in the ~/.basrc file. In your preferred terminal you can set the option “run command as a login shell”

This makes sure that the .bashrc always gets executed for the opening terminal.