Keep screen completely, absolutely, off

I am currently experimenting with coreos in a small home cluster.

All the machines have an HDMI output and, for the time being, they are all connected to my main monitor (mainly because I am redeploying 5 times a day… I’m still experimenting).

My problem is my monitor won’t turn off. I have set the consoleblank kernel arg to a non-zero value, I have created a custom unit file making use of setterm, nothing works!

I mean, consoleblank does trigger the blanking but does not turn off the screen whereas setterm does power the screen off but then turn it on when my monitor scans the other inputs before really going off. Currently, machine A goes off after 10 seconds, my monitor scans the other inputs, Machine B turns on and off after 10 seconds, my monitor scans the other inputs, Machine C turns on and off after 10 seconds, etc. (and yes, it cycles back…)

So my question is: is there a way to completely utterly disable video output unless the keyboard is actually used?

(Hardware contraptions with servomotors to plug and unplug the cables when the keyboard is in use won’t be considered… :stuck_out_tongue: And I can’t set my monitor to manual, there is no option for it)


Sorry to be confused, but I did not quite understand your use case. Why not just disconnect the monitor?

If your software way of making the HDMI output blank would work you would see nothing. If you disconnect the monitor it’s the same…
In the end result, you can also only just ssh into CoreOS and check whether the installation/provision was successful, can’t you?

Ahh, now I get it…
This is the additional requirement.

AFAIK a terminal that is shown there does not really have the “concept” of being used. it’s just always there and shows stuff.
So I’m afraid I cannot really help…

FWIW I have the same problem in Fedora and it drives me nuts. I have three screens, Laptop LCD + two external monitors. Plugging the monitors in/out is not feasible. I stop work at the end of the day by locking my screen. Those monitors turn off and on all night long. I just want them off until I hit the keyboard again to unlock the screen. It’s a waste of energy.

Do you have this with F34 Workstation? I have that with F33 Cinnamon, but not in F34 i3, so your problem it’s probably slightly different. I will look for how to fix it in Cinnamon, and that will probably work for Workstation too.