Intel ice driver issue in kernel >= 6.0.18

Hello everyone :slight_smile:

To contextualize: This is a networking driver issue on what can be defined(?) as an exotic (Intel E810 XXV) hardware, the new kernel (>= 6.0.18), and fedora 36 server(I haven’t yet tried out fedora 37 but I expect it to behave similarly).

Last week I updated the cluster I am working on moving from kernel 6.0.15 to 6.0.18. Nothing big on paper, but the Ethernet cards (2 x Intel E810 XXV) stopped working, or, to be more precise, they kept working if used separately but stopped when a bond gets created with the NM. This was tested on fedora 36, with fairly standard software installed. To solve the issue I downloaded the last ice driver from Intel and compiled it.

This week (yesterday) I was moving from kernel 6.0.18 to kernel 6.1.5 and the stock driver (in the linux repo under: ./drivers/net/ethernet/intel/ice) is still not working. Furthermore, this time I had to hack the Intel driver by adapting all the netif_napi_add calls (to the new kernel API) and another minor change.

Whom should I contact to make him aware of the issue, or where should I file a bug report? And a broader question: this is my first time with exotic hardware, so should I get prepared to encounter this behavior often?

Thanks in advance,