Fedora 36 intermittent freezing not associated with any tasks

HI Guys
Recently moved over from Zorin 4 weeks ago to Fedora 36.
I had no issues on Zorin but wanted a more mature OS so picked Fedora.
I have for the past 3 weeks had random freezing for 10 to 30 seconds.
I thought it was the browser at first, but it does it everywhere no matter task i do light or heavy.
Here are my specs i would like to fix it if possible

1 Like

It’s some five year old-ish hardware, but definitely shouldn’t be doing this. When this happens, do you notice anything interesting if you run journalctl --since -15m immediately after?

1 Like

I have tried and i get an error

Failed to parse timestamp: 15m

I’m on ~7 year old hardware here, and don’t see freezes so this is probably hardware specific.

Let’s try:

journalctl -b

this loads journals from current boot, more info here:

See here

Hi link to log done, i was on Zorin no issues only seeing it in Fedora

Have you tried switching to X11 vice wayland?

i dont like Xorg i like the desktop functions of Wayland
Are you suggesting Wayland is the issue ?

This looks incomplete—there should be a lot more than 25 lines there. These appear to be the first 25 lines only.

I believe it’s worth trying as a troubleshooting step.


You mean switching to something i hate :slight_smile:
Like try it for a day to see if i get any freezes

1 Like

What desktop functions of Wayland do you use? If it is gestures then touchegg is a decent replacement.

Kewl i will look into it just out of interest why is Wayland so hated every place i go i am told to swap to xorg. Also lots of software runs crap on Wayland

First, if you’re on the internet long enough, you’ll realize that people will complain about anything and everything. The Linux world is very much not an exception to that. It’s better to focus on finding what works for you rather than what people are complaining about today.

Wayland is better at quite a lot of things. Xorg has the benefit and downside of being very old, which means its bugs, which are numerous, are more comfortable to some who are used to dealing with them. There are very, very few applications left that still don’t work on Wayland (or with xwayland), but they exist.

That said, Wayland is a better protocol and is the standard moving forward. It’s sometimes useful to try Xorg just to rule out some variables with legacy dependent stuff (especially since you have an nVidia GPU). You can easily switch between them in Fedora on the login screen.

1 Like

This is not a complaint about Wayland. It is instead an acknowledgement of the fact that wayland is new and different than the old and mature xorg desktop. There are differences in how the two function.

Sometimes an issue will be seen in wayland that does not appear in xorg and troubleshooting involves trying different things to see where the problem occurs. If it is seen in wayland but not in xorg then that helps identify the cause and the developers have a pointer to the area of interest for fixing it.

The software running poorly on wayland is due to the switch and the packagers need to know so they can fix the app so it runs properly on both desktops.

I’d still start by looking at the logs before testing out individual components. Could you please post them so we can take a look?

journalctl -b > logs.txt

Then upload the logs file to whatever service. That’ll be the complete logs.

1 Like

I am on Xorg currently and had freezing already 2 times but only for a few seconds

For me it looks like a power problem because of too much usb ports/hubs. 16ports is quite a lot.

Log between line 716-725
* Aug 26 21:55:05 osopolar kernel: hub 1-0:1.0: USB hub found
* Aug 26 21:55:05 osopolar kernel: hub 1-0:1.0: 16 ports detected
* Aug 26 21:55:05 osopolar kernel: usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.18
* Aug 26 21:55:05 osopolar kernel: usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
* Aug 26 21:55:05 osopolar kernel: usb usb2: Product: xHCI Host Controller
* Aug 26 21:55:05 osopolar kernel: usb usb2: Manufacturer: Linux 5.18.19-200.fc36.x86_64 xhci-hcd
* Aug 26 21:55:05 osopolar kernel: usb usb2: SerialNumber: 0000:00:14.0
* Aug 26 21:55:05 osopolar kernel: hub 2-0:1.0: USB hub found
* Aug 26 21:55:05 osopolar kernel: hub 2-0:1.0: 8 ports detected
* Aug 26 21:55:05 osopolar kernel: usb: port power management may be unreliable



Good catch! That could definitely do it, especially if there’s no external power source on that hub or attached devices.


I don’t hate Wayland, I use it daily. I believe switching between Wayland and X for intermittent issues like this is often a valid data point that assists in troubleshooting.

1 Like