Random freezes on Fedora 36

Recently, my desktop running Fedora 36 has been experiencing random freezes

PC Specs:

Intel Core i3-10100
Gigabyte B460 Ultra Durable HD-3
16GB of DDR4 Ram

  • I’ll add more ram info when my computer keeps running long enough find out


After 1-10 minutes of use, my computer screen freezes, and is unresponsive.
I’ve tried rebooting with the NVidia and built in driver, and still get the issue.

If it remains stable enough, I’ll try and get a log.

I’ve been running Fedora for only a few days, so it shouldn’t be any old software causing the issue

What should I do to fix this? Do I just need a fresh install?

1 Like

What is the status when booted from the live install USB device?
Does it also hang / freeze?
Did such a freeze maybe interfere with the install so it did not complete properly?

If the PC does not freeze similarly with the install live media, then what was the status immediately after the install? Same? or no freeze?

Have you updated the system (sudo dnf update) since the install was completed? Did that complete properly?

The screen freeze may or may not indicate a full system freeze. Please try sudo dnf upgrade followed by sudo dnf distrosync and see what the result is.

After doing the above, please post the output of inxi -Fzx so we can see the full system specs.


When Live Booting with a USB with Ventoy the live media froze, but it worked fine after flashing it with Rufus.

I ran sudo dnf update when installing GPU drivers last

When running sudo dnf distorosync I got an output of

Last metadata expiration check: 0:05:15 ago on Tue 12 Jul 2022 16:32:34.
Dependencies resolved.
Nothing to do.

I got the same output for sudo dnf upgrade.

Unfortunately my computer would lock up when attempting to open firefox, so I need to send a photo that I took instead.
Photos from inxi output: Screenshots for Fedora forum - Album on Imgur

I am not sure why you did the screenshots? Was the system frozen? If the system was frozen how did you pan to different pages of that output?

You would have made things easier for us if you copied the text and pasted it here inside the </> Preformatted text tags on the toolbar above when posting.

It seems that you must be using a second computer to post if you are unable to use the browser on the computer that is ‘freezing’. You probably could use ssh to log into that computer and run those commands without being affected with the ‘freeze’ if it is firefox related.

1 Like

simply out of curiosity i tried the above command on my fedora 36 to see the full system specs

what i got is this :

~]$ inxi -Fzx
bash: inxi: command not found
~]$ sudo inxi -Fzx
[sudo] password for :
sudo: inxi: command not found

why :roll_eyes:

Inxi is not installed.
It may be installed with dnf install inxi after which the command would work.

1 Like

why did you not mention earlier that inxi needs to be installed for the command inxi -Fzx to work?

I did not mention that because routinely the message about the command not available also suggests that you install the needed package. Did you read that?

i posted exactly what i got when i used the command :

did you read that ???

1 Like

Try this as seen on my system just now. F36 fully updated with gnome and default configs

$ inxi
bash: inxi: command not found...
Install package 'inxi' to provide command 'inxi'? [N/y] 
1 Like

I forgot about SSH! Ill connect to it as soon as I’m back home

Fedora offered to install it for me so I don’t actually care

~]$ inxi
bash: inxi: command not found

no prompts to install nothing.

I just inxi through SSH, so here is the output

  Kernel: 5.18.10-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Console: pty pts/1 Distro: Fedora release 36 (Thirty Six)
  Type: Desktop System: Gigabyte product: B460HD3 v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: B460 HD3 v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F4b date: 03/18/2021
  Info: quad core model: Intel Core i3-10100 bits: 64 type: MT MCP
    arch: Comet Lake rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 4156 high: 4200 min/max: 800/4300 cores: 1: 4198 2: 4129
    3: 4172 4: 4197 5: 4156 6: 4100 7: 4102 8: 4200 bogomips: 57600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: Gigabyte
    driver: i915 v: kernel arch: Gen9.5 bus-ID: 00:02.0
  Device-2: NVIDIA TU117 [GeForce GTX 1650] vendor: ASUSTeK driver: nvidia
    v: 515.57 arch: Turing bus-ID: 01:00.0
  Display: server: X.org v: 1.20.14 with: Xwayland v: 22.1.2 driver:
    gpu: nvidia,nvidia-nvswitch note:  X driver n/a - try sudo/root tty: 84x24
    resolution: 1: 1920x1080 2: 1280x1024
  Message: GL data unavailable in console. Try -G --display
  Device-1: Intel Comet Lake PCH-V cAVS vendor: Gigabyte driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.18.10-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.54 running: yes
  Device-1: Realtek RTL8188EE Wireless Network Adapter driver: rtl8188ee
    v: kernel port: 4000 bus-ID: 02:00.0
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Gigabyte driver: r8169 v: kernel port: 3000 bus-ID: 04:00.0
  IF: enp4s0 state: down mac: <filter>
  Local Storage: total: 689.33 GiB used: 22.76 GiB (3.3%)
  ID-1: /dev/nvme0n1 vendor: Seagate model: BarraCuda Q5 ZP500CV30001
    size: 465.76 GiB temp: 19.9 C
  ID-2: /dev/sda vendor: Western Digital model: WDS240G2G0A-00JH30
    size: 223.57 GiB
  ID-1: / size: 464.17 GiB used: 22.54 GiB (4.9%) fs: btrfs dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 206.6 MiB (21.2%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 14 MiB (2.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 464.17 GiB used: 22.54 GiB (4.9%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0

It froze shortly after this, but it was still accepting commands through SSH.
I thought to have a looks at the remaining swap and ram, but they still looked fine.

               total        used        free      shared  buff/cache   available
Mem:        16139464     1484888     8734200       15456     5920376    14339344
Swap:        8388604           0     8388604

Could this be related to the GPU driver, or a broken install?

Can you try logging in from a tty? Press ctrl+alt+F3 and login from tty3 for example (enter your username and password). Given that you are still being able to use SSH while frozen, it looks like your DE (Gnome) is the one freezing not your whole system.

I suggest you to disable all gnome extensions at first.

It may be the Nvidia GPU causing problems.

1 Like

I’ll try that when I’m home.
Should I also try installing i3 or another lightweight DE, and see if that works

You do have 2 GPUs. The inxi shows it is desktop with a gigabyte mobo. Usually those GPUs would indicate a laptop, but in your case it seems you are using 2 monitors, with different resolutions.

Are both monitors attached to the same GPU or is one attached to one GPU (possibly the mobo) and the other attached to the nvidia gpu?

On my system if I use two different gpus at the same time I see similar ‘hesitations’. The DE seems to need time to figure out where the data belongs and which gpu to send it to.

Since the ssh session was still active that implies that the ‘freeze’ may be DE or graphics related.

You also appear to be using gnome with wayland, which means the system cannot properly take advantage of the hardware acceleration on the nvidia GPU. There are several threads here about hardware acceleration and slow rendering when not used.

You can try installing KDE plasma and run using an x11 session since walyand+nvidia may be problematic

You say the builtin NVidia driver. Doesn’t Fedora use Nouveau unless you install NVidia from rpmfusion. The random freeze thing used to happen to me when I didn’t use NVidia, but only happened with nouveau.

When I say Nvidia driver I mean the official proprietary one not nouveau. Yes what you said is true you need rpmfusion for proprietary driver.