My fedora 39 often freezes

I went through forum and I ran “dmesg --level=err,warn” and got the following

Most of the messages seems more or less usual to me.
The interesting is the:

systemd-journald[576]: File /var/log/journal/......./system.journal corrupted or uncleanly shut down, renaming, replacing.

You could start by looking there (in the old, rotated journals).

How often does the machine freeze? How long after the boot it happens?

You may try to isolate whether it is GUI issue by booting without GUI and waiting for the freeze

sudo systemctl set-default

and reboot
You’ll set the GUI booting again by:

sudo systemctl set-default

and reboot

Of all of these messages, the “failure to read thermal zone” is the most interesting. Overheating could definitely cause your machine to throttle and lock up. You might want to monitor the output of sensors to get a clue for potential overheating.

tried this, seems like booting without GUI did not had any issue

I have Nvidia 940mx graphic, but it seems not working. Though I have installed nvedia driver
please have a look

The nvidia GPU there is running with the nouveau driver.

Please post the output of mokutil --sb-state and dnf list installed \*nvidia\* so we can see the state of secure boot and the installed nvidia packages.

If secure boot is enabled then the nvidia driver will not be able to load unless it has been signed at compile time.

If this is something else we can usually figure that out.

Also, please post data that you copy & paste from your screen as preformatted text using the </> button so it is searchable and others looking for answers may find what you have shared.

Images are not searchable and often do not contain all the needed info.

1 Like

Here is the output for mokutil --sb-state and dnf list installed \*nvedia*\

❯ mokutil --sb-state
SecureBoot disabled
Platform is in Setup Mode
❯ dnf list installed \*nvedia\*
Error: No matching Packages to list

A typo ? Shouldn’t it be nvidia instead ?

sorry! yes you are right ,
Now that I correctly wrote the string I get this output

❯ dnf list installed \*nvidia\*
Installed Packages
nvidia-gpu-firmware.noarch               20231211-1.fc39                @updates

Ok, now we can see that you do not have the nvidia drivers installed, so only the nouveau driver is available for the nvidia GPU.

My belief is that there are apps running that require a lot of graphics and since nouveau does not seem to support hardware acceleration on the nvidia gpu it offloads graphics rendering to the CPU which slows performance drastically. The nvidia drivers automatically enable hardware acceleration with those GPUs.

If you wish to install the nvidia drivers to properly support the nvidia GPU then you need to verify that the rpmfusion repo is enabled. dnf repolist should show the rpmfusion-nonfree-nvidia-driver as one of the enabled repos.

If that repo is enabled then the command
sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda should install all the required packages. Wait at least 5 minutes after the install completes then reboot and the nvidia drivers should now load.

Loading of the drivers can be confirmed with lsmod | grep nvidia

1 Like