Fedora Workstation freezes

Hello, my computer with Fedora 39 is freezing. After logging in, the mouse and keyboard do not work, Capslock does not work, but there is an image on the monitor. I installed Windows 10, it works. Please help me.

Does the freeze occur immediately after login, or after some time ?

You say, all of that works until log-in, so you can use mouse and keyboard to fill in the password to log in.
Right ?

Before the log-in, try to press “CTRL+ ALT + F3” to switch to the TTY.
There, with the text interface only, try to log in and then run command:

dmesg --level=err,warn

to check for errors and warnings produced by kernel

journalctl -e

to read through the systemd journal.

1 Like

There was an Nvidia error. I deleted the drivers, now it does not hang, but without the driver, the monitor resolution is not determined. The drivers are not installed.


I have solved this problem. If in dmesg --level=err,warn is an error about Nvidia in this, reinstall the Nvidia GPU driver.

1 Like

What I have found with years of using the nvidia drivers is that often when using the automatic update the drivers do not properly get rebuilt before the system reboots, and this may happen with either a kernel update or a driver update.

Performing the updates manually using dnf from the command line allows the user to delay the reboot until the new driver modules are properly compiled and installed.

Yes, a reinstall of akmod-nvidia may solve the issue, though a different path using akmods with sudo akmods --force --kernels=$(uname -r) should fix the issue without removal and reinstall of the nvidia drivers as a whole.

The problem has repeated itself. it worked, then the keyboard and mouse stopped responding.

The message on that screenshot indicates that the GPU you have is older and supported by the 390xx drivers.
Please uninstall the existing nvidia drivers with sudo dnf remove \*nvidia\* --exclude nvidia-gpu-firmware then reinstall with sudo dnf install akmod-nvidia-390xx so the proper driver version is installed.

Note that the 390xx drivers are in the rpmfusion-nonfree repo so it must be enabled before you can install that version. If not already enabled the directions are here

1 Like