Desktop freezing up, requires hard restart | F40 | Nvidia

I’ve been using Fedora for more than a year now, but as of the past few weeks, been getting random freezes on my device. For context I am using a laptop, connected to an external monitor, keyboard and mouse.
When it freezes up, the mouse and keyboard don’t work, but I can still move the cursor using the trackpad, but the laptop keyboard doesnt work either. Now I have tried waiting but event after ~30 mins of inactivity the screen doesnt change at all, and then I am forced to power off via long pressing the power key.
I have tried disabling extensions, restarting with an older kernel, logging in with xorg, removed all nvidia drivers (I have mx130, had some drivers installed for this, but this wasnt being used, instead was getting message on boot up that nouveau drivers are being used)
After each of these changes, the freeze would not occur for a few hours, maybe for an entire day, but then again it would start.
Please help, I am a beginner, so unfamiliar on how to debug this, will attach whatever command output screenshots that are required.
am a beginner, and so far in terms of debugging

Added f40, gnome, wayland

Welcome to :fedora: !

You can start by providing your hardware info and some journalctl entries.

Please provide the reults of inxi -Fzxx here in preformatted text:

2024-05-06_12-15-49_Preformatted_Text

As for the journalctl commands, can you tell us if this happened recently ?

Here is one that would be useful for kernel messages

sudo journalctl -k | fpaste --raw-url

@hamrheadcorvette
Output of inxi -Fzxx

System:
  Kernel: 6.8.11-300.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: GNOME v: 46.2 tk: GTK v: 3.24.42 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 40 (Workstation Edition)
Machine:
  Type: Laptop System: Acer product: Aspire A515-52G v: V1.14
    serial: <superuser required>
  Mobo: WL model: Raticate_WL v: V1.14 serial: <superuser required>
    part-nu: 0000000000000000 UEFI: Insyde v: 1.14 date: 05/24/2019
Battery:
  ID-1: BAT1 charge: 20.2 Wh (54.4%) condition: 37.1/48.9 Wh (75.7%)
    volts: 14.9 min: 15.2 model: LG PABAS0241231 serial: <filter>
    status: discharging
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 2S
    serial: <filter> charge: 55% (should be ignored) status: discharging
CPU:
  Info: quad core model: Intel Core i5-8265U bits: 64 type: MT MCP
    arch: Whiskey Lake rev: B cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 1662 high: 2101 min/max: 400/3900 cores: 1: 2100 2: 2100
    3: 2101 4: 2101 5: 400 6: 400 7: 2100 8: 2001 bogomips: 28800
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620]
    vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-9.5 ports:
    active: eDP-1 empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:3ea0
  Device-2: NVIDIA GM108M [GeForce MX130] vendor: Acer Incorporated ALI
    driver: N/A arch: Maxwell pcie: speed: 8 GT/s lanes: 4 bus-ID: 01:00.0
    chip-ID: 10de:174d
  Device-3: Quanta HD Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-7:4 chip-ID: 0408:a060
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: BOE Display 0x07cb res: 1920x1080 dpi: 142
    diag: 394mm (15.5")
  API: OpenGL v: 4.6 vendor: intel mesa v: 24.1.2 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel UHD Graphics 620 (WHL GT2)
    device-ID: 8086:3ea0 display-ID: :0.0
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: Intel Cannon Point-LP High Definition Audio
    vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:9dc8
  API: ALSA v: k6.8.11-300.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin
Network:
  Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:9df0
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 02:00.1 chip-ID: 10ec:8168
  IF: enp2s0f1 state: down mac: <filter>
Bluetooth:
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 bus-ID: 1-10:5
    chip-ID: 8087:0aaa
  Report: btmgmt ID: hci0 rfk-id: 2 state: up address: <filter> bt-v: 5.1
    lmp-v: 10
Drives:
  Local Storage: total: 1.14 TiB used: 152.19 GiB (13.1%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8250G size: 232.89 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 36.9 C
  ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB
    speed: 6.0 Gb/s serial: <filter>
Partition:
  ID-1: / size: 231.3 GiB used: 85.45 GiB (36.9%) fs: btrfs
    dev: /dev/nvme0n1p3
  ID-2: /boot size: 973.4 MiB used: 864.3 MiB (88.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 231.3 GiB used: 85.45 GiB (36.9%) fs: btrfs
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 49.0 C pch: 60.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB available: 15.46 GiB used: 1.85 GiB (12.0%)
  Processes: 329 Power: uptime: 1m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 22 Compilers: gcc: 14.1.1 Shell: Bash
    v: 5.2.26 running-in: gnome-terminal inxi: 3.3.34

Output of sudo journalctl -k | fpaste --raw-url
https://paste.centos.org/view/raw/8edb3968

Taking this right after a freeze happened, and rebooted the system

Appreciate the help!

1 Like